summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-01-14 18:44:05 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-01-14 18:44:38 +0100
commitac9dd667df5bf993ae66bd24cffd351aed49d4c0 (patch)
tree1d00e4d14f6b8c8229beb73450dd6f2c158209e0 /app-misc/klavaro/klavaro-3.13.ebuild
parentsys-block/tgt: Update SRC_URI (diff)
downloadgentoo-ac9dd667df5bf993ae66bd24cffd351aed49d4c0.tar.gz
gentoo-ac9dd667df5bf993ae66bd24cffd351aed49d4c0.tar.bz2
gentoo-ac9dd667df5bf993ae66bd24cffd351aed49d4c0.zip
app-misc/klavaro: add 3.13
Closes: https://bugs.gentoo.org/734250 Closes: https://bugs.gentoo.org/831197 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-misc/klavaro/klavaro-3.13.ebuild')
-rw-r--r--app-misc/klavaro/klavaro-3.13.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/klavaro/klavaro-3.13.ebuild b/app-misc/klavaro/klavaro-3.13.ebuild
new file mode 100644
index 000000000000..ccb81f02cfd6
--- /dev/null
+++ b/app-misc/klavaro/klavaro-3.13.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools optfeature
+
+DESCRIPTION="Another free touch typing tutor program"
+HOMEPAGE="https://klavaro.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-util/intltool
+ >=sys-devel/gettext-0.18.3
+"
+RDEPEND="
+ dev-libs/glib:2
+ net-misc/curl
+ x11-libs/gtk+:3
+ >=x11-libs/gtkdatabox-1.0.0
+ x11-libs/pango
+"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # https://sourceforge.net/p/klavaro/patches/16/
+ "${FILESDIR}"/${PN}-3.13-datadir.patch
+ # https://sourceforge.net/p/klavaro/patches/17/
+ "${FILESDIR}"/${PN}-3.13-desktop-keywords.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+pkg_postinst() {
+ optfeature "instructions via synthesized speech" app-accessibility/espeak
+}