summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-09 18:23:25 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-09 18:34:42 +0200
commitb3d4a8a28fcab3918223c6ad6a76676912ee20b6 (patch)
treeb7891ac433ab68f0987c159f38d20d640684a929 /app-misc/kryoflux-dtc
parentsys-auth/pambase: Drop old (diff)
downloadgentoo-b3d4a8a28fcab3918223c6ad6a76676912ee20b6.tar.gz
gentoo-b3d4a8a28fcab3918223c6ad6a76676912ee20b6.tar.bz2
gentoo-b3d4a8a28fcab3918223c6ad6a76676912ee20b6.zip
app-misc/kryoflux-dtc: update kryoflux ui
Use newer UI from the newer windows version, which works just fine with the linux version. Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc/kryoflux-dtc')
-rw-r--r--app-misc/kryoflux-dtc/Manifest1
-rw-r--r--app-misc/kryoflux-dtc/kryoflux-dtc-2.6-r1.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/app-misc/kryoflux-dtc/Manifest b/app-misc/kryoflux-dtc/Manifest
index e6d215853fe9..a711ef324f68 100644
--- a/app-misc/kryoflux-dtc/Manifest
+++ b/app-misc/kryoflux-dtc/Manifest
@@ -1,2 +1,3 @@
DIST kryoflux-ui.jar 2101377 BLAKE2B db9922b9d5787772849d1ef9edae52d64de066f643c471412ed9129307c4ee399ec3a18ebcacd7428ab15eabf5307e916b678831f2fa456cbd7073aa60bbb574 SHA512 66ba81ed1b2a97a0391e513c45b19436f17677e3dfe7c063749e41763658f99a5eb92e5b3312f4151f8fc51bd79502ac11ffd895966117e1d5a9849867aeb957
DIST kryoflux_2.6_linux.tar.bz2 9177658 BLAKE2B 6eb0bc7a166950bfedb32da466c17125a8a7d64e4bc9aa6610c69dd0f98c2fb5187ad19dbaf191b33dcb5a786ec4a1fa9bce2464c3c04eb152e0b9ed7ae770f2 SHA512 9bf700e9c646bad135999eb1fed12c86ff6fbc11a0034b86af7541fb16a4905dd740c706ebb87bf5848f5d80f45699c350a56397df5b6850559c2576d18eef1b
+DIST kryoflux_3.00_windows.zip 18502294 BLAKE2B f8e60b0feb6e7d7b9a43480b0b4cf67b79c5431fa20ee9e771ee7adf214e1c992d080c2eb6a043f141936f2de873d63079e994b90e994051a29391c6a308f190 SHA512 12de0c7d28b0abca2eb35748770fe96906c12940b7148103f56713fe1144e09759d362a24c094a7088713557da467b90f4e3d0ace59252cb84e3349dc73ee5bd
diff --git a/app-misc/kryoflux-dtc/kryoflux-dtc-2.6-r1.ebuild b/app-misc/kryoflux-dtc/kryoflux-dtc-2.6-r1.ebuild
new file mode 100644
index 000000000000..35ec7750871b
--- /dev/null
+++ b/app-misc/kryoflux-dtc/kryoflux-dtc-2.6-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="kryoflux_${PV}_linux"
+MY_P_WINDOWS="kryoflux_3.00_windows"
+
+inherit desktop eutils udev xdg-utils
+
+DESCRIPTION="KryoFlux Host Software"
+HOMEPAGE="https://www.kryoflux.com"
+SRC_URI="
+ https://www.kryoflux.com/download/${MY_P}.tar.bz2
+ gui? ( https://www.kryoflux.com/download/${MY_P_WINDOWS}.zip )
+"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="SPS"
+SLOT="0"
+IUSE="demos doc fast-firmware gui static"
+
+RDEPEND="
+ dev-libs/spsdeclib
+ virtual/libusb:1
+ virtual/udev
+ gui? ( virtual/jre )
+"
+
+BDEPEND="app-arch/unzip"
+
+RESTRICT="bindist mirror"
+
+S="${WORKDIR}/${MY_P}"
+
+QA_PREBUILT="/usr/bin/kryoflux-dtc"
+
+src_unpack() {
+ unpack "${MY_P}".tar.bz2
+
+ if use gui; then
+ unpack "${MY_P_WINDOWS}".zip
+
+ # Extract kryoflux-ui.jar to get a logo for the meny entry
+ unpack "${MY_P_WINDOWS}"/dtc/kryoflux-ui.jar
+ fi
+}
+
+src_install() {
+ newbin dtc/$(usex amd64 x86_64 i686)/$(usex static static dynamic)/dtc kryoflux-dtc
+
+ cat <<-EOF > "${T}"/80-kryoflux.rules || die
+ ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="03eb", ATTR{idProduct}=="6124", GROUP="floppy", MODE="0660"
+ EOF
+ udev_dorules "${T}"/80-kryoflux.rules
+
+ if use gui; then
+ insinto /usr/share/kryoflux-ui
+ doins "${WORKDIR}"/"${MY_P_WINDOWS}"/dtc/kryoflux-ui.jar
+
+ dosym ../../bin/kryoflux-dtc /usr/share/kryoflux-ui/dtc
+
+ make_wrapper kryoflux-ui "java -jar kryoflux-ui.jar" /usr/share/kryoflux-ui
+
+ newicon "${WORKDIR}"/images/disk.png kryoflux-ui.png
+
+ make_desktop_entry "kryoflux-ui" "KryoFlux UI" kryoflux-ui Development
+
+ dodoc dtc/kryoflux-ui_README.txt
+ fi
+
+ if use fast-firmware; then
+ insinto /lib/firmware
+ doins dtc/firmware_fast/firmware_kf_usb_rosalie.bin
+
+ dodoc dtc/firmware_fast/firmware_fast_README.txt
+ else
+ insinto /lib/firmware
+ doins dtc/firmware_kf_usb_rosalie.bin
+ fi
+
+ if use demos; then
+ dodoc -r g64_demo ipf_demo
+ fi
+
+ if use doc; then
+ dodoc -r docs schematics
+ fi
+
+ local DOCS=( "DONATIONS.txt" "RELEASE.txt" "README.linux" )
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "If you want to access your Kryoflux without root access,"
+ elog "please add yourself to the floppy group."
+
+ if use fast-firmware; then
+ elog ""
+ elog "You have enabled the fast firmware. Please keep in mind,"
+ elog "that this firmware can cause trouble with older floppy drives."
+ fi
+
+ if use gui; then
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ fi
+}