summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-04-23 22:36:55 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-04-23 22:37:22 +0200
commitf02fbaa2c1c29de8c6b254ac1db310bb24b162f7 (patch)
tree7c8a78f9f4c46c6eea5febe65e48caab472785d2 /app-misc/kryoflux-dtc
parentdev-python/watchgod: Update remote-id as well (diff)
downloadgentoo-f02fbaa2c1c29de8c6b254ac1db310bb24b162f7.tar.gz
gentoo-f02fbaa2c1c29de8c6b254ac1db310bb24b162f7.tar.bz2
gentoo-f02fbaa2c1c29de8c6b254ac1db310bb24b162f7.zip
app-misc/kryoflux-dtc: add 3.00
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc/kryoflux-dtc')
-rw-r--r--app-misc/kryoflux-dtc/Manifest1
-rw-r--r--app-misc/kryoflux-dtc/kryoflux-dtc-3.00.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/app-misc/kryoflux-dtc/Manifest b/app-misc/kryoflux-dtc/Manifest
index b934da13382a..2a87dbcc9db7 100644
--- a/app-misc/kryoflux-dtc/Manifest
+++ b/app-misc/kryoflux-dtc/Manifest
@@ -1,2 +1,3 @@
DIST kryoflux_2.6_linux.tar.bz2 9177658 BLAKE2B 6eb0bc7a166950bfedb32da466c17125a8a7d64e4bc9aa6610c69dd0f98c2fb5187ad19dbaf191b33dcb5a786ec4a1fa9bce2464c3c04eb152e0b9ed7ae770f2 SHA512 9bf700e9c646bad135999eb1fed12c86ff6fbc11a0034b86af7541fb16a4905dd740c706ebb87bf5848f5d80f45699c350a56397df5b6850559c2576d18eef1b
+DIST kryoflux_3.00_linux.tgz 13921877 BLAKE2B aceb934ec7b0b9d5d1d96555dceeeaa5eb11af67b1aae91888376a2c7615d4ed135167d4c3ea0ae3851a378e5fd5934aacd557a57e28e824c9131efcb87bc59e SHA512 0f4e805373c769bc81659ff93d6f8001103a6a192ca30c73b84cde231d52aa51950860fb9e11c156800d40ebbcd7cc33253f0fcbd436e8668731836f9689c013
DIST kryoflux_3.00_windows.zip 18211783 BLAKE2B e50cfc196d37216a7c929c4aa915b5cfeb7f38805076aed4e1bbc9dbfcc946fce18db0a2e2020d77cf581e2df174f2e3b6eb2b3d9060795501b1769d258ad05d SHA512 afa42fd3460d796dd3694059a86484ea94ab3084c52dc18d6f14e5b790d66e0f13514fbe2efc5c32abd3e471cdb0ac10cc3f7bafcdfb41371a6caddda83e2a00
diff --git a/app-misc/kryoflux-dtc/kryoflux-dtc-3.00.ebuild b/app-misc/kryoflux-dtc/kryoflux-dtc-3.00.ebuild
new file mode 100644
index 000000000000..6fced826be94
--- /dev/null
+++ b/app-misc/kryoflux-dtc/kryoflux-dtc-3.00.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="kryoflux_${PV}_linux"
+MY_PV_DTC="3.0.0"
+MY_P_DTC="dtc-${MY_PV_DTC}-Linux"
+MY_P_WINDOWS="${MY_P/linux/windows}"
+
+inherit desktop udev wrapper xdg-utils
+
+DESCRIPTION="KryoFlux Host Software"
+HOMEPAGE="https://www.kryoflux.com"
+SRC_URI="https://www.kryoflux.com/download/${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
+
+KEYWORDS="-* ~amd64"
+LICENSE="SPS"
+SLOT="0"
+IUSE="demos doc gui"
+
+RDEPEND="
+ dev-libs/spsdeclib
+ virtual/libusb:1
+ gui? ( virtual/jre )
+"
+
+BDEPEND="
+ app-arch/unzip
+ dev-util/patchelf
+"
+
+DOCS=( "DONATIONS.txt" "RELEASE.txt" )
+RESTRICT="bindist mirror"
+QA_PREBUILT="/usr/bin/kryoflux-dtc"
+
+src_unpack() {
+ unpack ${A}
+ unpack ${MY_P}/dtc/$(usex amd64 x86_64 aarch64)/${MY_P_DTC}.tar.gz
+ use gui && unpack ${MY_P}/dtc/kryoflux-ui.jar
+}
+
+src_prepare() {
+ default
+
+ # Upstream uses 'libCAPSImage.so.5.1' (uppercase),
+ # but their source installs 'libcapsimage.so.5' (lowercase)
+ patchelf --replace-needed libCAPSImage.so.5.1 libcapsimage.so.5 ../${MY_P_DTC}/bin/dtc
+}
+
+src_install() {
+ newbin ../${MY_P_DTC}/bin/dtc kryoflux-dtc
+
+ insinto /lib/firmware
+ doins ../${MY_P_DTC}/share/dtc/firmware_kf_usb_rosalie.bin
+
+ cat <<-EOF > "${T}"/80-kryoflux.rules || die
+ ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="03eb", ATTR{idProduct}=="6124", GROUP="floppy", MODE="0660"
+ EOF
+ udev_dorules "${T}"/80-kryoflux.rules
+
+ if use gui; then
+ insinto /usr/share/kryoflux-ui
+ doins dtc/kryoflux-ui.jar
+
+ dosym ../../bin/kryoflux-dtc /usr/share/kryoflux-ui/dtc
+ make_wrapper kryoflux-ui "java -jar kryoflux-ui.jar" /usr/share/kryoflux-ui
+
+ newicon ../images/disk.png kryoflux-ui.png
+ make_desktop_entry "kryoflux-ui" "KryoFlux UI" kryoflux-ui Development
+ dodoc dtc/kryoflux-ui_README.txt
+ fi
+
+ if use demos; then
+ dodoc -r g64_demo ipf_demo
+ docompress -x /usr/share/doc/${PF}/g64_demo/BBSB/*.g64
+ docompress -x /usr/share/doc/${PF}/g64_demo/DOTC/*.g64
+ docompress -x /usr/share/doc/${PF}/ipf_demo/*.ipf
+ fi
+
+ if use doc; then
+ dodoc -r docs schematics
+ docompress -x /usr/share/doc/${PF}/{docs,schematics}/*.pdf
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "If you want to access your Kryoflux without root access,"
+ elog "please add yourself to the floppy group."
+
+ udev_reload
+
+ if use gui; then
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
+
+ if use gui; then
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ fi
+}