summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorŁukasz Zubkowicz <lukasek86@gmail.com>2020-03-08 13:29:56 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-04-01 17:37:33 +0300
commit2b68d6d20c7935eb3da1411f04fcbdbb76f761c6 (patch)
tree41f2f0ce43e20b835f520eb11690d54ea0bb75c3 /app-misc/ledit/ledit-2.04.ebuild
parentsci-libs/opencascade: drop old (diff)
downloadgentoo-2b68d6d20c7935eb3da1411f04fcbdbb76f761c6.tar.gz
gentoo-2b68d6d20c7935eb3da1411f04fcbdbb76f761c6.tar.bz2
gentoo-2b68d6d20c7935eb3da1411f04fcbdbb76f761c6.zip
app-misc/ledit: version bump to 2.04
Closes: https://bugs.gentoo.org/705584 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Łukasz Zubkowicz <lukasek86@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14865 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/ledit/ledit-2.04.ebuild')
-rw-r--r--app-misc/ledit/ledit-2.04.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/ledit/ledit-2.04.ebuild b/app-misc/ledit/ledit-2.04.ebuild
new file mode 100644
index 000000000000..e987e9a7848a
--- /dev/null
+++ b/app-misc/ledit/ledit-2.04.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A line editor to be used with interactive commands"
+SRC_URI="http://pauillac.inria.fr/~ddr/ledit/distrib/src/${P}.tgz"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/ledit/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+ocamlopt"
+RESTRICT="installsources !ocamlopt? ( strip )"
+
+DEPEND=">=dev-lang/ocaml-3.09:=[ocamlopt?]
+ dev-ml/camlp5:="
+RDEPEND="${DEPEND}"
+
+# For explanation please follow the link below.
+# https://github.com/gentoo/gentoo/pull/14865#issuecomment-605697524
+QA_FLAGS_IGNORED="/usr/bin/ledit"
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 ledit.opt
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ newbin ledit.opt ledit
+ else
+ newbin ledit.out ledit
+ fi
+ doman ledit.1
+ dodoc CHANGES README
+}