summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/linuxspa
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/linuxspa')
-rw-r--r--app-misc/linuxspa/Manifest1
-rw-r--r--app-misc/linuxspa/files/linuxspa-0.7.1-compile-fix.patch12
-rw-r--r--app-misc/linuxspa/linuxspa-0.7.1-r1.ebuild39
-rw-r--r--app-misc/linuxspa/linuxspa-0.7.1.ebuild34
-rw-r--r--app-misc/linuxspa/metadata.xml11
5 files changed, 97 insertions, 0 deletions
diff --git a/app-misc/linuxspa/Manifest b/app-misc/linuxspa/Manifest
new file mode 100644
index 000000000000..a497c6e9c632
--- /dev/null
+++ b/app-misc/linuxspa/Manifest
@@ -0,0 +1 @@
+DIST LinuxSPA-0.7.1.tgz 45448 SHA256 7acef814174e2007d201f8b14a432075ede3709317c4632916dcca04187c97d1 SHA512 4b622330e88abe7d4b91392e75ef8d90902b731e051a7bdc93895aa82b6ae33a5e65bbe950c8d6884985cf8b7bdb1c3dd46b24d75f7c90a872e0a7758f929673 WHIRLPOOL 62c7b04590cd43886b06199f6357370af90f77a1c59cdd277db763ea43535a4833c499f5ea42ca948b3ac1326db19c4c580fd4b0f09568c90d7cf31851869b82
diff --git a/app-misc/linuxspa/files/linuxspa-0.7.1-compile-fix.patch b/app-misc/linuxspa/files/linuxspa-0.7.1-compile-fix.patch
new file mode 100644
index 000000000000..d8a3c858647b
--- /dev/null
+++ b/app-misc/linuxspa/files/linuxspa-0.7.1-compile-fix.patch
@@ -0,0 +1,12 @@
+diff -ur a/std232.c b/std232.c
+--- a/std232.c 2003-07-18 22:08:33.000000000 -0300
++++ b/std232.c 2006-05-11 21:31:33.000000000 -0300
+@@ -89,7 +89,7 @@
+ {
+ unsigned int index;
+
+- (unsigned int) index = strtol(temp, NULL, 16);
++ index = strtol(temp, NULL, 16);
+ if (index < 256)
+ return (&cmatrix[index][0]);
+ else return (&dmatrix[0]);
diff --git a/app-misc/linuxspa/linuxspa-0.7.1-r1.ebuild b/app-misc/linuxspa/linuxspa-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..55a8c856a35f
--- /dev/null
+++ b/app-misc/linuxspa/linuxspa-0.7.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_PN="LinuxSPA"
+DESCRIPTION="Linux Serial Protocol Analyser"
+HOMEPAGE="http://sourceforge.net/projects/serialsniffer/"
+SRC_URI="mirror://sourceforge/serialsniffer/${MY_PN}-${PV}.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-compile-fix.patch
+ sed -i Makefile \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wall" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin LinuxSPA std232
+ dodoc ASCII_Filter.txt BCircuit.txt LinuxSPA.png READING_Materials.txt \
+ README TODO connector-1a.ps connector-2a.ps cooked.file raw.file
+}
diff --git a/app-misc/linuxspa/linuxspa-0.7.1.ebuild b/app-misc/linuxspa/linuxspa-0.7.1.ebuild
new file mode 100644
index 000000000000..5a3b084544f8
--- /dev/null
+++ b/app-misc/linuxspa/linuxspa-0.7.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Linux Serial Protocol Analyser"
+HOMEPAGE="http://sourceforge.net/projects/serialsniffer/"
+SRC_URI="mirror://sourceforge/serialsniffer/LinuxSPA-0.7.1.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+MY_PN="LinuxSPA"
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-compile-fix.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin LinuxSPA std232
+ insinto /usr/share/doc/${P}
+ doins ASCII_Filter.txt BCircuit.txt LinuxSPA.png READING_Materials.txt
+ doins README TODO connector-1a.ps connector-2a.ps cooked.file raw.file
+}
diff --git a/app-misc/linuxspa/metadata.xml b/app-misc/linuxspa/metadata.xml
new file mode 100644
index 000000000000..10bb7f173697
--- /dev/null
+++ b/app-misc/linuxspa/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>Linux Serial Protocol Analyser</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">serialsniffer</remote-id>
+ </upstream>
+</pkgmetadata>