summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-25 10:47:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-25 11:27:08 +0100
commita125b5b090a9c7637fa256b5eb72fda4257762fc (patch)
treeba044fa60f140fee21e35ea1ff14cb9f3d06b929 /app-misc/media-player-info
parentgames-arcade/commandergenius: EAPI7->8, enable py3.11, filter-lto (diff)
downloadgentoo-a125b5b090a9c7637fa256b5eb72fda4257762fc.tar.gz
gentoo-a125b5b090a9c7637fa256b5eb72fda4257762fc.tar.bz2
gentoo-a125b5b090a9c7637fa256b5eb72fda4257762fc.zip
app-misc/media-player-info: update EAPI 7 -> 8, python3_11
Fedora uses python3_11 since 37 without additional patching. Closes: https://bugs.gentoo.org/896590 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-misc/media-player-info')
-rw-r--r--app-misc/media-player-info/media-player-info-24-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-misc/media-player-info/media-player-info-24-r1.ebuild b/app-misc/media-player-info/media-player-info-24-r1.ebuild
new file mode 100644
index 000000000000..6dc0ad8e730e
--- /dev/null
+++ b/app-misc/media-player-info/media-player-info-24-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-any-r1 udev
+
+DESCRIPTION="Repository of data files describing media player capabilities"
+HOMEPAGE="https://gitlab.freedesktop.org/media-player-info/media-player-info"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+# Upstream commit d83dd01a0a1df6198ee08954da1c033b88a1004b
+RDEPEND=">=virtual/udev-208"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS NEWS )
+
+pkg_postinst() {
+ # Run for /lib/udev/hwdb.d/20-usb-media-players.hwdb
+ udevadm hwdb --update --root="${ROOT}"
+ # Upstream commit 1fab57c209035f7e66198343074e9cee06718bda
+ if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
+ return 0
+ fi
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}