summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-11 11:59:54 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-11 11:59:54 -0400
commit28a61d271f12604285852fcbe20b4bfa1b454cde (patch)
tree98db890a11c00240ba5abfa53f4874f7dff3f35a /app-misc/mosquitto
parentapp-misc/mosquitto: bump version to 1.5.1 (diff)
downloadgentoo-28a61d271f12604285852fcbe20b4bfa1b454cde.tar.gz
gentoo-28a61d271f12604285852fcbe20b4bfa1b454cde.tar.bz2
gentoo-28a61d271f12604285852fcbe20b4bfa1b454cde.zip
app-misc/mosquitto: remove old
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-misc/mosquitto')
-rw-r--r--app-misc/mosquitto/Manifest1
-rw-r--r--app-misc/mosquitto/mosquitto-1.4.14-r1.ebuild97
-rw-r--r--app-misc/mosquitto/mosquitto-1.4.15-r3.ebuild102
-rw-r--r--app-misc/mosquitto/mosquitto-1.4.15.ebuild99
4 files changed, 0 insertions, 299 deletions
diff --git a/app-misc/mosquitto/Manifest b/app-misc/mosquitto/Manifest
index 83420091448d..edeb703fb8b4 100644
--- a/app-misc/mosquitto/Manifest
+++ b/app-misc/mosquitto/Manifest
@@ -1,3 +1,2 @@
DIST mosquitto-1.4.14.tar.gz 365596 BLAKE2B 92bcb1fd9e67711d6ce8db5e767be31a1321866205cf4cad684d8b77a8b14a2eaf5e4367a74d5dd8f814f0d229dc77ce878879632c0c34c6a23f7975bf6ae8c7 SHA512 dc75a971354f87deeb79f32435acfae9bc561a1a24a75ee4940a35176ff91758071930d2105d8dee2a090e07527dbfaa5692bece67e03cc87e8b4b8b46f846c2
-DIST mosquitto-1.4.15.tar.gz 368961 BLAKE2B 28bfab7d41d9e057ba8b52e0c428967ecc5d0c25a3d73dca420ae883c2b462ee02da1eeb9c22f4d392f0ccf62224acab6f24d4a0798a594f4b9f90c907fa1495 SHA512 36b06547553cf28af3ca9b728c42fc27e849c4ae84d7964572d430233ab26e2b59eee2a215ac23ddf2d0bef419e7c70e64e2a22c397fadb3e0677314d03f1100
DIST mosquitto-1.5.1.tar.gz 430066 BLAKE2B ab2df1b77cfcb71c95d3412c4c3da4cf0af1a48d700642a12c8e0334762e9e8868ba0cbd69311d7aa324f2920d3be227149ba4e0bd7558ba10e5d7d1f0b24996 SHA512 7b076a977778ca87f9fa4579eb4a6b62b171df746920719e9bd6efce0a4815c15edc9da177669819509184d2b01ed0756be8259adba344df690efe0547fd6741
diff --git a/app-misc/mosquitto/mosquitto-1.4.14-r1.ebuild b/app-misc/mosquitto/mosquitto-1.4.14-r1.ebuild
deleted file mode 100644
index 96530da48cb2..000000000000
--- a/app-misc/mosquitto/mosquitto-1.4.14-r1.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit systemd user toolchain-funcs python-any-r1
-
-DESCRIPTION="An Open Source MQTT v3 Broker"
-HOMEPAGE="http://mosquitto.org/"
-SRC_URI="http://mosquitto.org/files/source/${P}.tar.gz"
-LICENSE="EPL-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="bridge examples +persistence +srv ssl tcpd websockets"
-
-RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
- ssl? ( dev-libs/openssl:0= )"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- srv? ( net-dns/c-ares )
- websockets? ( net-libs/libwebsockets )"
-
-pkg_setup() {
- enewgroup mosquitto
- enewuser mosquitto -1 -1 -1 mosquitto
-}
-
-src_prepare() {
- eapply "${FILESDIR}/${PN}-1.4.10-conditional-tests.patch"
- if use persistence; then
- sed -i -e "s:^#autosave_interval:autosave_interval:" \
- -e "s:^#persistence false$:persistence true:" \
- -e "s:^#persistence_file:persistence_file:" \
- -e "s:^#persistence_location$:persistence_location /var/lib/mosquitto/:" \
- mosquitto.conf || die
- fi
-
- # Remove prestripping
- sed -i -e 's/-s --strip-program=${CROSS_COMPILE}${STRIP}//'\
- client/Makefile lib/cpp/Makefile src/Makefile lib/Makefile || die
-
- python_setup
- python_fix_shebang test
- eapply_user
-}
-
-src_configure() {
- LIBDIR=$(get_libdir)
- makeopts=(
- "CC=$(tc-getCC)"
- "LIB_SUFFIX=${LIBDIR:3}"
- "WITH_BRIDGE=$(usex bridge)"
- "WITH_PERSISTENCE=$(usex persistence)"
- "WITH_SRV=$(usex srv)"
- "WITH_TLS=$(usex ssl)"
- "WITH_WEBSOCKETS=$(usex websockets)"
- "WITH_WRAP=$(usex tcpd)"
- )
-}
-
-src_compile() {
- emake "${makeopts[@]}"
-}
-
-src_test() {
- emake "${makeopts[@]}" test
-}
-
-src_install() {
- emake "${makeopts[@]}" DESTDIR="${D}" prefix=/usr install
- keepdir /var/lib/mosquitto
- fowners mosquitto:mosquitto /var/lib/mosquitto
- dodoc readme.md CONTRIBUTING.md ChangeLog.txt
- doinitd "${FILESDIR}"/mosquitto
- insinto /etc/mosquitto
- doins mosquitto.conf
- systemd_dounit "${FILESDIR}/mosquitto.service"
-
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/*
- fi
-}
-
-pkg_postinst() {
- elog ""
- elog "The Python module has been moved out of mosquitto."
- elog "See http://mosquitto.org/documentation/python/"
- elog ""
- elog "To start the mosquitto daemon at boot, add it to the default runlevel with:"
- elog ""
- elog " rc-update add mosquitto default"
- elog " or"
- elog " systemctl enable mosquitto"
-}
diff --git a/app-misc/mosquitto/mosquitto-1.4.15-r3.ebuild b/app-misc/mosquitto/mosquitto-1.4.15-r3.ebuild
deleted file mode 100644
index 8905f6d3f499..000000000000
--- a/app-misc/mosquitto/mosquitto-1.4.15-r3.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit systemd user toolchain-funcs python-any-r1
-
-DESCRIPTION="An Open Source MQTT v3 Broker"
-HOMEPAGE="https://mosquitto.org/"
-SRC_URI="https://mosquitto.org/files/source/${P}.tar.gz"
-
-LICENSE="EPL-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="bridge examples +persistence +srv ssl tcpd test websockets"
-
-REQUIRED_USE="test? ( bridge )"
-
-RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
- ssl? ( dev-libs/openssl:0= )"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- srv? ( net-dns/c-ares )
- websockets? ( net-libs/libwebsockets )"
-
-PATCHES=( "${FILESDIR}/${PN}-fix-conditional-tests.patch" )
-
-_emake() {
- LIBDIR=$(get_libdir)
- emake \
- CC="$(tc-getCC)" \
- LIB_SUFFIX="${LIBDIR:3}" \
- WITH_BRIDGE="$(usex bridge)" \
- WITH_PERSISTENCE="$(usex persistence)" \
- WITH_SRV="$(usex srv)" \
- WITH_TLS="$(usex ssl)" \
- WITH_WEBSOCKETS="$(usex websockets)" \
- WITH_WRAP="$(usex tcpd)" \
- "$@"
-}
-
-pkg_setup() {
- enewgroup mosquitto
- enewuser mosquitto -1 -1 -1 mosquitto
-}
-
-src_prepare() {
- default
- if use persistence; then
- sed -i -e "/^#autosave_interval/s|^#||" \
- -e "s|^#persistence false$|persistence true|" \
- -e "/^#persistence_file/s|^#||" \
- -e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \
- mosquitto.conf || die
- fi
-
- # Remove prestripping
- sed -i -e 's/-s --strip-program=${CROSS_COMPILE}${STRIP}//'\
- client/Makefile lib/cpp/Makefile src/Makefile lib/Makefile || die
-
- python_setup
- python_fix_shebang test
-}
-
-src_compile() {
- _emake
-}
-
-src_test() {
- _emake test
-}
-
-src_install() {
- _emake DESTDIR="${D}" prefix=/usr install
- keepdir /var/lib/mosquitto
- fowners mosquitto:mosquitto /var/lib/mosquitto
- dodoc readme.md CONTRIBUTING.md ChangeLog.txt
- doinitd "${FILESDIR}"/mosquitto
- insinto /etc/mosquitto
- doins mosquitto.conf
- systemd_dounit "${FILESDIR}/mosquitto.service"
-
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto "/usr/share/doc/${PF}"
- doins -r examples
- fi
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog "The Python module has been moved out of mosquitto."
- elog "See https://mosquitto.org/documentation/python/"
- else
- elog "To start the mosquitto daemon at boot, add it to the default runlevel with:"
- elog ""
- elog " rc-update add mosquitto default"
- elog " or"
- elog " systemctl enable mosquitto"
- fi
-}
diff --git a/app-misc/mosquitto/mosquitto-1.4.15.ebuild b/app-misc/mosquitto/mosquitto-1.4.15.ebuild
deleted file mode 100644
index 65dffc2f3f19..000000000000
--- a/app-misc/mosquitto/mosquitto-1.4.15.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit systemd user toolchain-funcs python-any-r1
-
-DESCRIPTION="An Open Source MQTT v3 Broker"
-HOMEPAGE="http://mosquitto.org/"
-SRC_URI="http://mosquitto.org/files/source/${P}.tar.gz"
-
-LICENSE="EPL-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="bridge examples +persistence +srv ssl tcpd test websockets"
-
-REQUIRED_USE="test? ( bridge )"
-
-RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
- ssl? ( dev-libs/openssl:0= )"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- srv? ( net-dns/c-ares )
- websockets? ( net-libs/libwebsockets )"
-
-_emake() {
- LIBDIR=$(get_libdir)
- emake \
- CC="$(tc-getCC)" \
- LIB_SUFFIX="${LIBDIR:3}" \
- WITH_BRIDGE="$(usex bridge)" \
- WITH_PERSISTENCE="$(usex persistence)" \
- WITH_SRV="$(usex srv)" \
- WITH_TLS="$(usex ssl)" \
- WITH_WEBSOCKETS="$(usex websockets)" \
- WITH_WRAP="$(usex tcpd)" \
- "$@"
-}
-
-pkg_setup() {
- enewgroup mosquitto
- enewuser mosquitto -1 -1 -1 mosquitto
-}
-
-src_prepare() {
- if use persistence; then
- sed -i -e "/^#autosave_interval/s|^#||" \
- -e "s|^#persistence false$|persistence true|" \
- -e "/^#persistence_file/s|^#||" \
- -e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \
- mosquitto.conf || die
- fi
-
- # Remove prestripping
- sed -i -e 's/-s --strip-program=${CROSS_COMPILE}${STRIP}//'\
- client/Makefile lib/cpp/Makefile src/Makefile lib/Makefile || die
-
- python_setup
- python_fix_shebang test
- eapply_user
-}
-
-src_compile() {
- _emake
-}
-
-src_test() {
- _emake test
-}
-
-src_install() {
- _emake DESTDIR="${D}" prefix=/usr install
- keepdir /var/lib/mosquitto
- fowners mosquitto:mosquitto /var/lib/mosquitto
- dodoc readme.md CONTRIBUTING.md ChangeLog.txt
- doinitd "${FILESDIR}"/mosquitto
- insinto /etc/mosquitto
- doins mosquitto.conf
- systemd_dounit "${FILESDIR}/mosquitto.service"
-
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto "/usr/share/doc/${PF}"
- doins -r examples
- fi
-}
-
-pkg_postinst() {
- elog ""
- elog "The Python module has been moved out of mosquitto."
- elog "See http://mosquitto.org/documentation/python/"
- elog ""
- elog "To start the mosquitto daemon at boot, add it to the default runlevel with:"
- elog ""
- elog " rc-update add mosquitto default"
- elog " or"
- elog " systemctl enable mosquitto"
-}