summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-09-26 13:54:27 -0700
committerMatt Turner <mattst88@gentoo.org>2019-09-27 09:18:47 -0700
commit4b7136842b37b19feb43720adc615c971681d7b4 (patch)
tree798550c42e432fc41d18d23d90b75cddb613dbd2 /app-misc/mosquitto
parentacct-user/mosquitto: Add 'mosquitto' user (UID 482) (diff)
downloadgentoo-4b7136842b37b19feb43720adc615c971681d7b4.tar.gz
gentoo-4b7136842b37b19feb43720adc615c971681d7b4.tar.bz2
gentoo-4b7136842b37b19feb43720adc615c971681d7b4.zip
app-misc/mosquitto: Version bump to 1.6.7
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-misc/mosquitto')
-rw-r--r--app-misc/mosquitto/Manifest1
-rw-r--r--app-misc/mosquitto/mosquitto-1.6.7.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/app-misc/mosquitto/Manifest b/app-misc/mosquitto/Manifest
index f3c840ee08f9..1dd940be2afc 100644
--- a/app-misc/mosquitto/Manifest
+++ b/app-misc/mosquitto/Manifest
@@ -1,3 +1,4 @@
DIST mosquitto-1.5.6.tar.gz 439402 BLAKE2B 7d887d7d2e02d9891613d441c76705c40744cd8c7acae330648e5a00560b4ba1fbc28b92ac84bf85d423c84de875c5309f364d04fca72516ab2276fe42512b0c SHA512 99bd935f93ae25f0c7992870780cce4748b35ffd58fd0d39e20ee69f34c28d3eac289cf0c7dec078dbdced3bda12da4569d4b5e84ebdaa5514640f331ca3238b
DIST mosquitto-1.5.8.tar.gz 442834 BLAKE2B be5a7c2e7d28da0101fdfac9e5b0d7499abb71b464df3da11637c141947c75631e9c8952b219d20d598a156d0f8d5e86151c65ee4b55443dcef9c30eff49e3b3 SHA512 5cf2ae59077878be2784cc83fefe00fa3ff904646711545be519fc48557319c56dc7c15682fffc0dc42c530cdf59f550f25da9eec50a1a7deb222aa11bb669d3
DIST mosquitto-1.6.2.tar.gz 576747 BLAKE2B c0815f1f0a964ee5cc26fc9a1d3c222b5261e29e1520f2b3ddacbe61e1af44c47040db1d9b71721f6ef9b42f378d1974d994065a8558a1f3f759dc5ca81db1a7 SHA512 d1c13df4409eb20ccc00a67b07a4af5c5ce668a403a4605e2bae4f5869b256ebe5d9a001d009cb0e34bc7b3cfee96779fc81099b170ff03af3ca43f05567912b
+DIST mosquitto-1.6.7.tar.gz 591062 BLAKE2B a215e311197fd84f1fa1ff0b681c8d1157db1a3e538a5a16afa1f11d17a08a720d44ae16b306cb08d6b585c8c4d4b2e38df972ceebc4634c727f4c8e0994c170 SHA512 0a75cf192483053ce78c6d9e3be158bdf66366d7731a68cf29e24731f6936027af1d86045c2b973f642e42e58efa033dbfd17842e3e95550bac4c1f44ab346e9
diff --git a/app-misc/mosquitto/mosquitto-1.6.7.ebuild b/app-misc/mosquitto/mosquitto-1.6.7.ebuild
new file mode 100644
index 000000000000..c259a27c56d6
--- /dev/null
+++ b/app-misc/mosquitto/mosquitto-1.6.7.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit python-any-r1 systemd toolchain-funcs
+
+DESCRIPTION="An Open Source MQTT v3 Broker"
+HOMEPAGE="https://mosquitto.org/"
+SRC_URI="https://mosquitto.org/files/source/${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="bridge examples +persistence +srv ssl tcpd test websockets"
+
+REQUIRED_USE="test? ( bridge )"
+
+RDEPEND="
+ acct-user/mosquitto
+ acct-group/mosquitto
+ srv? ( net-dns/c-ares:= )
+ ssl? ( dev-libs/openssl:0= )
+ tcpd? ( sys-apps/tcp-wrappers )"
+
+DEPEND="${PYTHON_DEPS}
+ ${RDEPEND}
+ test? ( dev-util/cunit )
+ websockets? ( net-libs/libwebsockets )"
+
+_emake() {
+ local LIBDIR=$(get_libdir)
+ emake \
+ CC="$(tc-getCC)" \
+ CLIENT_LDFLAGS="${LDFLAGS}" \
+ LIB_SUFFIX="${LIBDIR:3}" \
+ WITH_BRIDGE="$(usex bridge)" \
+ WITH_PERSISTENCE="$(usex persistence)" \
+ WITH_SRV="$(usex srv)" \
+ WITH_TLS="$(usex ssl)" \
+ WITH_WEBSOCKETS="$(usex websockets)" \
+ WITH_WRAP="$(usex tcpd)" \
+ "$@"
+}
+
+src_prepare() {
+ default
+ if use persistence; then
+ sed -i -e "/^#autosave_interval/s|^#||" \
+ -e "s|^#persistence false$|persistence true|" \
+ -e "/^#persistence_file/s|^#||" \
+ -e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \
+ mosquitto.conf || die
+ fi
+
+ # Remove prestripping
+ sed -i -e 's/-s --strip-program=${CROSS_COMPILE}${STRIP}//'\
+ client/Makefile lib/cpp/Makefile src/Makefile lib/Makefile || die
+
+ # Remove failing tests
+ sed -i -e '/02-subpub-qos1-bad-pubcomp.py/d' \
+ -e '/02-subpub-qos1-bad-pubrec.py/d' \
+ -e '/02-subpub-qos2-bad-puback-1.py/d' \
+ -e '/02-subpub-qos2-bad-puback-2.py/d' \
+ -e '/02-subpub-qos2-bad-pubcomp.py/d' \
+ test/broker/Makefile || die
+ sed -i -e '/02-subscribe-qos1-async2.test/d' \
+ test/lib/Makefile || die
+
+ python_setup
+ python_fix_shebang test
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake test
+}
+
+src_install() {
+ _emake DESTDIR="${D}" prefix=/usr install
+ keepdir /var/lib/mosquitto
+ fowners mosquitto:mosquitto /var/lib/mosquitto
+ dodoc readme.md CONTRIBUTING.md ChangeLog.txt
+ doinitd "${FILESDIR}"/mosquitto
+ insinto /etc/mosquitto
+ doins mosquitto.conf
+ systemd_dounit "${FILESDIR}/mosquitto.service"
+
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "The Python module has been moved out of mosquitto."
+ elog "See https://mosquitto.org/documentation/python/"
+ else
+ elog "To start the mosquitto daemon at boot, add it to the default runlevel with:"
+ elog ""
+ elog " rc-update add mosquitto default"
+ elog "or"
+ elog " systemctl enable mosquitto"
+ fi
+}