summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/muttprint/muttprint-0.73-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/muttprint/muttprint-0.73-r1.ebuild')
-rw-r--r--app-misc/muttprint/muttprint-0.73-r1.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/app-misc/muttprint/muttprint-0.73-r1.ebuild b/app-misc/muttprint/muttprint-0.73-r1.ebuild
new file mode 100644
index 000000000000..6609a9df793b
--- /dev/null
+++ b/app-misc/muttprint/muttprint-0.73-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Script for pretty printing of your mails"
+HOMEPAGE="http://muttprint.sourceforge.net"
+SRC_URI="mirror://sourceforge/muttprint/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="doc"
+
+DEPEND="dev-lang/perl
+ virtual/latex-base
+ doc? (
+ app-text/dvipsk
+ app-text/docbook-sgml-utils[jadetex] )"
+
+RDEPEND="dev-lang/perl
+ virtual/latex-base
+ dev-texlive/texlive-latexextra"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+patch_docs() {
+ sed -i -e 's/db2pdf/docbook2pdf/' "${S}"/configure.ac || die
+ for l in de en es it sl
+ do
+ sed -i -e "/^docdir/s/$/-${PV}/" \
+ -e 's/db2/docbook2/' -e 's/ -s / -d /' \
+ -e "s|manual-${l}-sed/||" \
+ -e "s/mv manual-${l}-sed.dvi/cp manual-${l}-sed.dvi/" \
+ "${S}"/doc/manual/${l}/Makefile.am || die
+ done
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-warning.patch"
+ epatch "${FILESDIR}/${P}-manuals.patch"
+
+ if use doc ; then
+ # Patch docbook and docdir
+ patch_docs
+ else
+ # Don't do manuals
+ sed -i -e '/db2pdf/d' "${S}"/configure.ac || die
+ fi
+ sed -i -e "/^docdir/s/$/-${PV}/" "${S}"/Makefile.am || die
+
+ # The distfile does not include the png files, nor penguin.jpg
+ sed -i -e '/.*png /d' -e '/penguin.jpg /d' "${S}"/pics/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${PF}"
+}
+
+src_compile() {
+ # Parallel build does not work when USE="doc"
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog
+}