summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/mvcase/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/mvcase/files')
-rw-r--r--app-misc/mvcase/files/mvcase-0.1-flags.patch25
-rw-r--r--app-misc/mvcase/files/mvcase-0.1-includes.patch25
2 files changed, 50 insertions, 0 deletions
diff --git a/app-misc/mvcase/files/mvcase-0.1-flags.patch b/app-misc/mvcase/files/mvcase-0.1-flags.patch
new file mode 100644
index 000000000000..e0a9e99160f8
--- /dev/null
+++ b/app-misc/mvcase/files/mvcase-0.1-flags.patch
@@ -0,0 +1,25 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Nov 14 23:22:15 UTC 2012
+Subject: build system
+
+ respect CC, CFLAGS and LDFLAGS
+
+--- mvcase-0.1/Makefile
++++ mvcase-0.1/Makefile
+@@ -6,14 +6,13 @@
+ MANPATH=/usr/man
+ COMPILE=gcc
+ ROFF=groff
+-CFLAGS=
+-CLIBS=-lshhopt
++LIBS=-lshhopt
+ INSTALL=install
+
+ all: mvcase mvcase.1.gz
+
+ mvcase: mvcase.c
+- $(COMPILE) $(CFLAGS) mvcase.c -o mvcase $(CLIBS)
++ $(CC) $(CFLAGS) mvcase.c -o mvcase $(LDFLAGS) $(LIBS)
+
+ mvcase.1.gz: mvcase.1
+ $(ROFF) -man -Tascii mvcase.1 | gzip > mvcase.1.gz
diff --git a/app-misc/mvcase/files/mvcase-0.1-includes.patch b/app-misc/mvcase/files/mvcase-0.1-includes.patch
new file mode 100644
index 000000000000..095f07a06780
--- /dev/null
+++ b/app-misc/mvcase/files/mvcase-0.1-includes.patch
@@ -0,0 +1,25 @@
+* Fix compiler warnings.
+* Remove unused variable.
+
+--- a/mvcase.c
++++ b/mvcase.c
+@@ -17,6 +17,10 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h> /* exit() free() realloc() */
++#include <string.h> /* strlen() strcpy() */
++#include <strings.h> /* rindex() */
++#include <ctype.h> /* tolower() toupper() */
+ #include <shhopt.h>
+
+ #define VERSION_INT 0
+@@ -45,7 +45,7 @@
+
+ int main (int argc, char **argv)
+ {
+- int i,j,k;
++ int i,j;
+ int static flag_upper = 0;
+ int static flag_lower = 0;
+ int static flag_path = 0;