summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-11-24 19:53:38 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-11-24 19:54:02 +0000
commit0f69a565612708062ba66583780bb3fb606e503a (patch)
tree96aa480d2c358b424f1fc88bf7821693d8f4a51b /app-misc/pax-utils/pax-utils-1.2.3-r3.ebuild
parentdev-libs/boost: backport spsc_queue.hpp include fix (diff)
downloadgentoo-0f69a565612708062ba66583780bb3fb606e503a.tar.gz
gentoo-0f69a565612708062ba66583780bb3fb606e503a.tar.bz2
gentoo-0f69a565612708062ba66583780bb3fb606e503a.zip
app-misc/pax-utils: backport python-3.7 support, bug #671522
Fix by Oleksandr Natalenko: lddtree.py: use errno properly os.errno interface is removed [1], thus should not be used. In fact, it is not used in other places of lddtree.py, so fix this one too, because it breaks --copy-to-tree on systems with Python 3.7. [1] https://bugs.python.org/issue33666 Closes: https://bugs.gentoo.org/671522 Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-misc/pax-utils/pax-utils-1.2.3-r3.ebuild')
-rw-r--r--app-misc/pax-utils/pax-utils-1.2.3-r3.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/app-misc/pax-utils/pax-utils-1.2.3-r3.ebuild b/app-misc/pax-utils/pax-utils-1.2.3-r3.ebuild
new file mode 100644
index 000000000000..880abaa929a9
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-1.2.3-r3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit eutils python-single-r1 toolchain-funcs unpacker
+
+DESCRIPTION="ELF utils that can check files for security relevant properties"
+HOMEPAGE="https://wiki.gentoo.org/index.php?title=Project:Hardened/PaX_Utilities"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="caps debug python seccomp"
+
+RDEPEND="caps? ( >=sys-libs/libcap-2.24 )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pyelftools[${PYTHON_USEDEP}]
+ )
+ seccomp? ( sys-libs/libseccomp )"
+DEPEND="${RDEPEND}
+ caps? ( virtual/pkgconfig )
+ seccomp? ( virtual/pkgconfig )
+ app-arch/xz-utils"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python-3.7.patch
+)
+
+_emake() {
+ emake \
+ USE_CAP=$(usex caps) \
+ USE_DEBUG=$(usex debug) \
+ USE_PYTHON=$(usex python) \
+ USE_SECCOMP=$(usex seccomp) \
+ "$@"
+}
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ # Avoid slow configure+gnulib+make if on an up-to-date Linux system
+ if use prefix || ! use kernel_linux ||
+ has_version '<sys-libs/glibc-2.10'
+ then
+ econf $(use_with caps) $(use_with debug) $(use_with python) $(use_with seccomp)
+ else
+ tc-export CC PKG_CONFIG
+ fi
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ _emake DESTDIR="${D}" PKGDOCDIR='$(DOCDIR)'/${PF} install
+
+ use python && python_fix_shebang "${ED}"/usr/bin/lddtree
+}