summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-22 22:20:31 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-22 22:35:52 +0100
commit24fed0bc22601919de9e39eb63fded980fe186ed (patch)
tree6e37680c6ff5f0312639495daffcc04f84a3cd9a /app-misc/pax-utils/pax-utils-1.3.3.ebuild
parentdev-python/phonenumbers: Bump to 8.12.28 (diff)
downloadgentoo-24fed0bc22601919de9e39eb63fded980fe186ed.tar.gz
gentoo-24fed0bc22601919de9e39eb63fded980fe186ed.tar.bz2
gentoo-24fed0bc22601919de9e39eb63fded980fe186ed.zip
app-misc/pax-utils: bump up to 1.3.3 (glibc-2.34 compatible)
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-misc/pax-utils/pax-utils-1.3.3.ebuild')
-rw-r--r--app-misc/pax-utils/pax-utils-1.3.3.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/app-misc/pax-utils/pax-utils-1.3.3.ebuild b/app-misc/pax-utils/pax-utils-1.3.3.ebuild
new file mode 100644
index 000000000000..0a9b82a4936b
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-1.3.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit python-single-r1 toolchain-funcs
+
+DESCRIPTION="ELF utils that can check files for security relevant properties"
+HOMEPAGE="https://wiki.gentoo.org/index.php?title=Project:Hardened/PaX_Utilities"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="caps debug kernel_linux python seccomp"
+
+RDEPEND="caps? ( >=sys-libs/libcap-2.24 )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pyelftools[${PYTHON_USEDEP}]
+ ')
+ )
+"
+# >=linux-headers-5.8 to pick linux headers with faccessat2, bug #768624
+DEPEND="
+ ${RDEPEND}
+ kernel_linux? ( !prefix-guest? ( >=sys-kernel/linux-headers-5.8 ) )
+"
+BDEPEND="
+ caps? ( virtual/pkgconfig )
+"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+_emake() {
+ emake \
+ USE_CAP=$(usex caps) \
+ USE_DEBUG=$(usex debug) \
+ USE_PYTHON=$(usex python) \
+ USE_SECCOMP=$(usex seccomp) \
+ "$@"
+}
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ # Avoid slow configure+gnulib+make if on an up-to-date Linux system
+ if use prefix || ! use kernel_linux; then
+ econf $(use_with caps) $(use_with debug) $(use_with python) $(use_with seccomp)
+ else
+ tc-export CC PKG_CONFIG
+ fi
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ _emake DESTDIR="${D}" PKGDOCDIR='$(DOCDIR)'/${PF} install
+
+ use python && python_fix_shebang "${ED}"/usr/bin/lddtree
+}