summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/pdfpc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/pdfpc')
-rw-r--r--app-misc/pdfpc/Manifest2
-rw-r--r--app-misc/pdfpc/metadata.xml11
-rw-r--r--app-misc/pdfpc/pdfpc-3.1.1.ebuild30
-rw-r--r--app-misc/pdfpc/pdfpc-4.0.0-r1.ebuild43
4 files changed, 86 insertions, 0 deletions
diff --git a/app-misc/pdfpc/Manifest b/app-misc/pdfpc/Manifest
new file mode 100644
index 000000000000..9af3ea7e7588
--- /dev/null
+++ b/app-misc/pdfpc/Manifest
@@ -0,0 +1,2 @@
+DIST pdfpc-3.1.1.tgz 199004 SHA256 ec5ffb9c2b55d1bac76172a6a13ed527ceed8cf0d659aca5e302f6a7185f00f2 SHA512 554203094b18fe11fd085414961de6644df3c258ad52d46ad171cfd6c2199028bcbaa9560bdaba63d83f858b467407cc276972b34f341cc25260db1d1358e88d WHIRLPOOL bddcba6a4285ea2b58dd01f76b7b050db630eaa97de5bba32a66f7f85563e6a99763a52e82286297f605dfa59d9ff918007baab297e587968ac1c83e3d69e8a8
+DIST pdfpc-v4.0.0.tar.gz 71039 SHA256 c091c554f4e3ed8735df40055253459c47b09590775a6f9b5b6abf1b42647a62 SHA512 2c822dee9c47be4858a9a20c729864120335b506d1271d032635653e394db3934bf0a1c261d6bcfeb416918e5c20553de688106fa2ad40834f91f75bf11a231d WHIRLPOOL f52f05bb9073505fc798c6182fb73e1b94fc007304105b1d038a5d6fcb791616e6afc2a42e02ef76bd0fc1a1cdd446cd8866ea4d08bba7a655428ffbe7266a3a
diff --git a/app-misc/pdfpc/metadata.xml b/app-misc/pdfpc/metadata.xml
new file mode 100644
index 000000000000..6fba54ab8c23
--- /dev/null
+++ b/app-misc/pdfpc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pdfpc/pdfpc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/pdfpc/pdfpc-3.1.1.ebuild b/app-misc/pdfpc/pdfpc-3.1.1.ebuild
new file mode 100644
index 000000000000..ca28658f0ac7
--- /dev/null
+++ b/app-misc/pdfpc/pdfpc-3.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Presenter console with multi-monitor support for PDF files"
+HOMEPAGE="http://davvil.github.com/pdfpc/"
+SRC_URI="mirror://github/davvil/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="app-text/poppler:=[cairo]
+ dev-libs/glib:2
+ dev-libs/libgee:0
+ gnome-base/librsvg
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+
+src_configure(){
+ local mycmakeargs=(
+ -DSYSCONFDIR="${EPREFIX}/etc"
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-misc/pdfpc/pdfpc-4.0.0-r1.ebuild b/app-misc/pdfpc/pdfpc-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..d88d3c24423d
--- /dev/null
+++ b/app-misc/pdfpc/pdfpc-4.0.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VALA_MIN_API_VERSION="0.26"
+VALA_MAX_API_VERSION="0.28" # fix sed line if you increase this
+
+inherit vala cmake-utils
+
+DESCRIPTION="Presenter console with multi-monitor support for PDF files"
+HOMEPAGE="http://pdfpc.github.io"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/poppler:=[cairo]
+ dev-libs/glib:2
+ dev-libs/libgee:0.8
+ gnome-base/librsvg
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ $(vala_depend)"
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_prepare() {
+ sed -i -e "s/valac-0.20/valac-0.28 valac-0.26/" cmake/Vala_CMake/vala/FindVala.cmake || die
+ vala_src_prepare
+}
+
+src_configure(){
+ local mycmakeargs=(
+ -DSYSCONFDIR="${EPREFIX}/etc"
+ )
+ cmake-utils_src_configure
+}