summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Barker <alex@1stleg.com>2021-06-12 12:02:35 -0700
committerSam James <sam@gentoo.org>2021-06-13 04:08:55 +0000
commit9fa1831607ae3ffc54f731dfadddb544f9098f67 (patch)
tree37d296bd93a88a66c8fe45f5a9cb0de109bf67dd /app-misc/piper/piper-0.5.1-r1.ebuild
parentapp-crypt/gpgme: Stabilize 1.15.1 ppc, #795495 (diff)
downloadgentoo-9fa1831607ae3ffc54f731dfadddb544f9098f67.tar.gz
gentoo-9fa1831607ae3ffc54f731dfadddb544f9098f67.tar.bz2
gentoo-9fa1831607ae3ffc54f731dfadddb544f9098f67.zip
app-misc/piper: needs dev-python/pygobject built with USE=cairo
Closes: https://bugs.gentoo.org/792732 Signed-off-by: Alex Barker <alex@1stleg.com> Closes: https://github.com/gentoo/gentoo/pull/21212 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/piper/piper-0.5.1-r1.ebuild')
-rw-r--r--app-misc/piper/piper-0.5.1-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/piper/piper-0.5.1-r1.ebuild b/app-misc/piper/piper-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..594522ebf5c6
--- /dev/null
+++ b/app-misc/piper/piper-0.5.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit meson python-single-r1 udev
+
+DESCRIPTION="GTK configuration application for libratbag"
+HOMEPAGE="https://github.com/libratbag/piper"
+SRC_URI="https://github.com/libratbag/piper/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/gobject-introspection
+ >=dev-libs/libratbag-0.13
+ gnome-base/librsvg[introspection]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_MULTI_USEDEP}]
+ dev-python/python-evdev[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/libevdev
+ virtual/libudev
+"
+
+src_configure() {
+ python_setup
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}"/usr/bin/
+}