summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-08-23 08:53:27 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-23 21:53:15 +0200
commitced858e6b6a454705d725e2f31d1d942e7667b04 (patch)
tree691bdda43f79ba8c7cd92dc2e4045f17535daa2f /app-misc/radeontop/radeontop-9999.ebuild
parentgames-roguelike/nethack: Bump to 3.6.1 (diff)
downloadgentoo-ced858e6b6a454705d725e2f31d1d942e7667b04.tar.gz
gentoo-ced858e6b6a454705d725e2f31d1d942e7667b04.tar.bz2
gentoo-ced858e6b6a454705d725e2f31d1d942e7667b04.zip
move x11-apps/radeontop -> app-misc/radeontop
Closes: https://bugs.gentoo.org/571848
Diffstat (limited to 'app-misc/radeontop/radeontop-9999.ebuild')
-rw-r--r--app-misc/radeontop/radeontop-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/radeontop/radeontop-9999.ebuild b/app-misc/radeontop/radeontop-9999.ebuild
new file mode 100644
index 000000000000..4c1bafa1eb80
--- /dev/null
+++ b/app-misc/radeontop/radeontop-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs git-r3
+
+DESCRIPTION="Utility to view Radeon GPU utilization"
+HOMEPAGE="https://github.com/clbr/radeontop"
+EGIT_REPO_URI="https://github.com/clbr/radeontop.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ x11-libs/libdrm
+ x11-libs/libpciaccess
+ x11-libs/libxcb
+ nls? (
+ sys-libs/ncurses:0=[unicode]
+ virtual/libintl
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ tc-export CC
+ export LIBDIR=$(get_libdir)
+ export nls=$(usex nls 1 0)
+ export amdgpu=1
+ export xcb=1
+ # Do not add -g or -s to CFLAGS
+ export plain=1
+}