summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2022-08-08 23:07:33 -0700
committerJoonas Niilola <juippis@gentoo.org>2022-08-16 11:42:00 +0300
commitb151e19c38ae315bc7f6d604148de91dd7f80a00 (patch)
tree39f1cab99640c910adae1c8b69fb1528d83d91bb /app-misc/remind
parentapp-misc/remind: add myself as a maintainer (diff)
downloadgentoo-b151e19c38ae315bc7f6d604148de91dd7f80a00.tar.gz
gentoo-b151e19c38ae315bc7f6d604148de91dd7f80a00.tar.bz2
gentoo-b151e19c38ae315bc7f6d604148de91dd7f80a00.zip
app-misc/remind: add 04.00.02
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Closes: https://bugs.gentoo.org/832175 Closes: https://github.com/gentoo/gentoo/pull/26576 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/remind')
-rw-r--r--app-misc/remind/Manifest1
-rw-r--r--app-misc/remind/remind-04.00.02.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-misc/remind/Manifest b/app-misc/remind/Manifest
index 122e6dc0db61..e81fa877c8f0 100644
--- a/app-misc/remind/Manifest
+++ b/app-misc/remind/Manifest
@@ -1 +1,2 @@
DIST remind-03.03.05.tar.gz 402481 BLAKE2B 8fabc3269a06aaf3502c2245653442ddf6c101c3f62718769418c28850da467d210f381ef3452e95b6dbc921fe06979b4c38be8b7389a9defd76865da66080f3 SHA512 56b37dfc50a6c6a8a284691d7f1c39d542b7309ec12a029c65b68f7921cd43521d3cef9fc8d21f4a9f4a7609b0e00013e7f2793b529f39f80d63ae1fe5194fd4
+DIST remind-04.00.02.tar.gz 465760 BLAKE2B fa31747ab8d9aa39da7904334f908a7275932b3fe39919e0aca5b8b5877b5597322aca8916f6fee04ff5c6fa15070f867145596f64c0ab0dfdbebe9f4be97e31 SHA512 655427f1ce246c0911f5896db2c565d77f5046c9bb35675efb74df07b04b247e31882d03062f9797fac24c14994c435a3f1e39194442a278cda67b4de1db851a
diff --git a/app-misc/remind/remind-04.00.02.ebuild b/app-misc/remind/remind-04.00.02.ebuild
new file mode 100644
index 000000000000..c2184f326a8e
--- /dev/null
+++ b/app-misc/remind/remind-04.00.02.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Ridiculously functional reminder program"
+HOMEPAGE="https://dianne.skoll.ca/projects/remind/"
+SRC_URI="https://dianne.skoll.ca/projects/remind/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="tk"
+
+RDEPEND="
+ tk? ( >=dev-lang/tk-8.5 dev-tcltk/tcllib )
+"
+DEPEND="${RDEPEND}
+ dev-perl/Cairo
+ dev-perl/JSON-MaybeXS
+ dev-perl/Pango
+ virtual/perl-Getopt-Long
+"
+DOCS="docs/* examples/defs.rem "
+
+src_prepare() {
+ default
+ sed -i 's:$(MAKE) -C src install:&-nostripped:' "${S}"/Makefile || die
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]] ; then
+ ewarn "Testing fails if run as root. Skipping tests"
+ else
+ emake test
+ fi
+}
+
+src_install() {
+ default
+
+ if ! use tk ; then
+ rm \
+ "${D}"/usr/bin/tkremind \
+ "${D}"/usr/share/man/man1/tkremind* \
+ || die
+ fi
+
+ rm "${S}"/contrib/rem2ics-*/{Makefile,rem2ics.spec} || die
+ insinto /usr/share/${PN}
+ doins -r contrib/
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/remind.vim
+}