summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-01-05 01:31:11 +0100
committerSebastian Pipping <sping@gentoo.org>2024-01-05 16:46:34 +0100
commit61a56b72f82db351d87ef24a7d554221a4b91a32 (patch)
tree7d220de9450a964f49bfbd08235f53bc8cecf1cb /app-misc/resolve-march-native
parentsys-kernel/gentoo-sources: add 6.6.10,update CPU Opt patch (diff)
downloadgentoo-61a56b72f82db351d87ef24a7d554221a4b91a32.tar.gz
gentoo-61a56b72f82db351d87ef24a7d554221a4b91a32.tar.bz2
gentoo-61a56b72f82db351d87ef24a7d554221a4b91a32.zip
app-misc/resolve-march-native: 5.0.2
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'app-misc/resolve-march-native')
-rw-r--r--app-misc/resolve-march-native/Manifest1
-rw-r--r--app-misc/resolve-march-native/resolve-march-native-5.0.2.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/app-misc/resolve-march-native/Manifest b/app-misc/resolve-march-native/Manifest
index de30de52a121..774a80b6cbfc 100644
--- a/app-misc/resolve-march-native/Manifest
+++ b/app-misc/resolve-march-native/Manifest
@@ -3,3 +3,4 @@ DIST resolve-march-native-3.0.0.tar.gz 15866 BLAKE2B fcfcac3cb1219d332c8db6a5b44
DIST resolve-march-native-4.0.0.tar.gz 18648 BLAKE2B 1d6757aed66da2f41b622d74b594c54c34fc5ebe3f47518ed959313e60cbe5f2fc04aa87f9781f82322b27642ce4a4315acd6f27b9b1f727e6533bd5c9130cd8 SHA512 375f3eeaea76cf53d29fb338cc73b647db7bf2456adb6e09c25bd1f92b8bc521844cfcae117fd0b02d280896f542d1209c118a33a0cbd8dce3ceec3873c8c85f
DIST resolve-march-native-4.1.0.tar.gz 20309 BLAKE2B e702d974db69d3e1e06d66d3f7a8aacd2d68077c105bf0b5147f5e3ab647d95009e96de5551f1ba9740872a2bbb08cffd65b6e3da495fbafafb2fa6312bf8551 SHA512 11ca0d982aad183687ce8a52f407cef73a2e843c1b227ba4fed72bae7927b8bc342d6a8adcc7da20a5ebc9c85a79f598cd2e0b603206b0b5c7f070e4b71c09a7
DIST resolve-march-native-5.0.1.tar.gz 42875 BLAKE2B 0e4795eb9caa02af95ff74406760c01cbab827e7d6928779d59bcf9dc9f230049f932f9236e10024fd4df3b191728e72d86f464f8dc956e579a10cd7eb012425 SHA512 0613f0ea7fed19e9497aa7e237cbe527febb11faafc12d372a0b059c6a57e285e6b109175385547267596a9ee5b97b6368fca676f4c6023768bc87a7351cd0ba
+DIST resolve-march-native-5.0.2.tar.gz 44486 BLAKE2B 2b6554cefabb17d9d931d2e1316d52203630971958091ba721ebeef77411c1c19385a7e4bc8c31bd9c781459f041aeb9a301b796be634f2a77a1418cf2a76d8a SHA512 272841289ab3695e9407beb289e42b56b67ddde594ee6b794ebb9cf2915a97f595f056985f62febcfeea3137e62400b389c586e849c4871b65d559130021633e
diff --git a/app-misc/resolve-march-native/resolve-march-native-5.0.2.ebuild b/app-misc/resolve-march-native/resolve-march-native-5.0.2.ebuild
new file mode 100644
index 000000000000..6f559f3d29f3
--- /dev/null
+++ b/app-misc/resolve-march-native/resolve-march-native-5.0.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Resolve GCC flag -march=native"
+HOMEPAGE="https://github.com/hartwork/resolve-march-native"
+SRC_URI="https://github.com/hartwork/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.2"
+
+distutils_enable_tests pytest