summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-02 23:51:45 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-02 23:51:45 +0200
commitc03e15f24d13d9750badb4bec8916a316918d7fc (patch)
tree588681f9b9261489f87cc3a1d3c74936d472339d /app-misc/rlwrap
parentapp-editors/atom: Version bump to 1.16.0. (diff)
downloadgentoo-c03e15f24d13d9750badb4bec8916a316918d7fc.tar.gz
gentoo-c03e15f24d13d9750badb4bec8916a316918d7fc.tar.bz2
gentoo-c03e15f24d13d9750badb4bec8916a316918d7fc.zip
app-misc/rlwrap: EAPI 6 bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-misc/rlwrap')
-rw-r--r--app-misc/rlwrap/rlwrap-0.42-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/rlwrap/rlwrap-0.42-r1.ebuild b/app-misc/rlwrap/rlwrap-0.42-r1.ebuild
new file mode 100644
index 000000000000..04b4ba3e9f2f
--- /dev/null
+++ b/app-misc/rlwrap/rlwrap-0.42-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="GNU readline wrapper"
+HOMEPAGE="http://utopia.knoware.nl/~hlub/uck/rlwrap/"
+SRC_URI="http://utopia.knoware.nl/~hlub/uck/rlwrap/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug"
+
+RDEPEND="sys-libs/readline:0="
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README )
+
+src_configure() {
+ econf \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+}