summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-06-30 00:38:48 +0300
committerAaron Bauman <bman@gentoo.org>2020-11-28 12:46:40 -0500
commit21c3d9ba810ae35fe90b7a5c5ba0ebdb6b502f70 (patch)
tree75184d496c7bfa24efe805354b25bfa3102cbcce /app-misc/rox-filer/rox-filer-2.11.ebuild
parentdev-util/dropwatch: drop old (diff)
downloadgentoo-21c3d9ba810ae35fe90b7a5c5ba0ebdb6b502f70.tar.gz
gentoo-21c3d9ba810ae35fe90b7a5c5ba0ebdb6b502f70.tar.bz2
gentoo-21c3d9ba810ae35fe90b7a5c5ba0ebdb6b502f70.zip
app-misc/rox-filer: fix compilation with GCC10
Updated ebuild to EAPI7, fixed compilation with -fno-common. Closes: https://bugs.gentoo.org/710330 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16499 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'app-misc/rox-filer/rox-filer-2.11.ebuild')
-rw-r--r--app-misc/rox-filer/rox-filer-2.11.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/app-misc/rox-filer/rox-filer-2.11.ebuild b/app-misc/rox-filer/rox-filer-2.11.ebuild
index 6b9abf2b53dc..966f2750cf96 100644
--- a/app-misc/rox-filer/rox-filer-2.11.ebuild
+++ b/app-misc/rox-filer/rox-filer-2.11.ebuild
@@ -1,18 +1,17 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit desktop epatch virtualx
+inherit desktop virtualx
DESCRIPTION="ROX-Filer a drag and drop spatial file manager"
-HOMEPAGE="http://rox.sourceforge.net/desktop"
-SRC_URI="mirror://sourceforge/rox/${P}.tar.bz2"
+HOMEPAGE="http://rox.sourceforge.net/desktop/ROX-Filer.html"
+SRC_URI="https://download.sourceforge.net/rox/${P}.tar.bz2"
-LICENSE="GPL-2 LGPL-2"
+LICENSE="GPL-2+ LGPL-2+"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE=""
COMMON_DEPEND="dev-lang/perl
dev-libs/libxml2:2
@@ -22,13 +21,18 @@ RDEPEND="${COMMON_DEPEND}
x11-misc/shared-mime-info"
DEPEND="${COMMON_DEPEND}
dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig"
+ sys-devel/gettext"
+BDEPEND="virtual/pkgconfig"
-S="${WORKDIR}/${P}"/ROX-Filer/src
+S="${WORKDIR}/${P}/ROX-Filer/src"
+
+PATCHES=(
+ "${FILESDIR}/${P}-in-source-build.patch"
+ "${FILESDIR}/${P}-gcc10.patch"
+)
src_prepare() {
- epatch "${FILESDIR}/${P}-in-source-build.patch"
+ default
sed -i -e 's:g_strdup(getenv("APP_DIR")):"/usr/share/rox":' \
main.c || die "sed failed"