summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-18 08:56:59 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-18 09:44:48 +0100
commita782fec3c129d380878d1a5c9605985918132989 (patch)
tree13d767240715d161720515b1da7c0663e4345269 /app-misc/screenfetch/screenfetch-9999.ebuild
parentMake sys-devel/gettext optional via the 'nls' USE flag, primarily so it can b... (diff)
downloadgentoo-a782fec3c129d380878d1a5c9605985918132989.tar.gz
gentoo-a782fec3c129d380878d1a5c9605985918132989.tar.bz2
gentoo-a782fec3c129d380878d1a5c9605985918132989.zip
app-misc/screenfetch: Version Bump
transfered changes to live ebuild Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-misc/screenfetch/screenfetch-9999.ebuild')
-rw-r--r--app-misc/screenfetch/screenfetch-9999.ebuild30
1 files changed, 14 insertions, 16 deletions
diff --git a/app-misc/screenfetch/screenfetch-9999.ebuild b/app-misc/screenfetch/screenfetch-9999.ebuild
index 8157a0064ac4..615fa7e5ff88 100644
--- a/app-misc/screenfetch/screenfetch-9999.ebuild
+++ b/app-misc/screenfetch/screenfetch-9999.ebuild
@@ -1,31 +1,29 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
+
+inherit eutils git-r3
MY_PN="${PN/f/F}"
-DESCRIPTION="A Bash Screenshot Information Tool"
+
+DESCRIPTION="Bash Screenshot Information Tool"
HOMEPAGE="https://github.com/KittyKatt/screenFetch"
-if [[ ${PV} == *9999* ]]; then
- inherit git-2
- EGIT_REPO_URI="https://github.com/KittyKatt/screenFetch"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/KittyKatt/${MY_PN}/archive/v${PV}.tar.gz -> \
- ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${MY_PN}-${PV}"
-fi
+EGIT_REPO_URI="https://github.com/KittyKatt/screenFetch"
LICENSE="GPL-3"
SLOT="0"
+KEYWORDS=""
IUSE="X"
-DEPEND=""
-RDEPEND="X? ( media-gfx/scrot x11-apps/xdpyinfo )"
-
src_install() {
newbin ${PN}-dev ${PN}
dodoc CHANGELOG README.mkdn TODO
}
+
+pkg_postinst() {
+ optfeature "resoluton detection" x11-apps/xdpyinfo
+ optfeature "screenshot taking" media-gfx/scrot
+ optfeature "screenshot uploading" net-misc/curl
+}