summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/tablix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/tablix')
-rw-r--r--app-misc/tablix/Manifest1
-rw-r--r--app-misc/tablix/metadata.xml9
-rw-r--r--app-misc/tablix/tablix-0.3.5-r1.ebuild59
3 files changed, 69 insertions, 0 deletions
diff --git a/app-misc/tablix/Manifest b/app-misc/tablix/Manifest
new file mode 100644
index 000000000000..498edc1680b8
--- /dev/null
+++ b/app-misc/tablix/Manifest
@@ -0,0 +1 @@
+DIST tablix2-0.3.5.tar.gz 4361294 SHA256 800ad85cb15d654a200a1b72969c219e29cbe5f55d4f092e316e52062083fd1d SHA512 bc5a892182185904ae836d4218668d23d9dfe7a593101ee26554212e71aabcb1d4a75fa2f09ce0635af46b03861759695418f4113abafe387de66b3e9be1b6d2 WHIRLPOOL c3ebae34df9844fa7d8a5c5702ae78e87504a201a8081ce40e273ca1b73b420dd2a5178cf956e859a95fa6d688f71283d819d52bcf1c56c8a6667ca8e57084b2
diff --git a/app-misc/tablix/metadata.xml b/app-misc/tablix/metadata.xml
new file mode 100644
index 000000000000..189ede33672d
--- /dev/null
+++ b/app-misc/tablix/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+<use>
+ <flag name='pvm'>Add support for parallel virtual machine
+ (<pkg>sys-cluster/pvm</pkg>)</flag>
+</use>
+</pkgmetadata>
diff --git a/app-misc/tablix/tablix-0.3.5-r1.ebuild b/app-misc/tablix/tablix-0.3.5-r1.ebuild
new file mode 100644
index 000000000000..8c1feee3393f
--- /dev/null
+++ b/app-misc/tablix/tablix-0.3.5-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit eutils autotools
+
+MY_PV="${PN}2-${PV}"
+
+DESCRIPTION="Tablix is a powerful free software kernel for solving general timetabling problems"
+HOMEPAGE="http://www.tablix.org/"
+SRC_URI="http://www.tablix.org/releases/stable/${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="pvm"
+
+DEPEND=">=dev-libs/libxml2-2.4.3
+ pvm? ( sys-cluster/pvm )"
+
+S="${WORKDIR}/${MY_PV}"
+
+pkg_setup() {
+ if ! use pvm; then
+ ewarn
+ ewarn "Without parallel virtual machine support, tablix will not be able"
+ ewarn "to solve even moderately complex problems. Even if you are using"
+ ewarn "a single machine, USE=pvm is highly recommended."
+ ewarn
+ epause 5
+ fi
+}
+
+src_prepare() {
+ sed -i "/^localedir/s:/locale:/share/${PN}/locale:" configure.in \
+ || die "sed failed"
+ sed -i "/^ACLOCAL_AMFLAGS/s:^:#:" Makefile.am \
+ || die "sed failed"
+ eautoreconf
+ # fix compilation when no optimizations are enabled wrt bug #240046
+ sed -i -e '32 d' -e '34 d' src/master.c || die "sed failed"
+ sed -i -e '31 d' -e '33 d' src/main.c || die "sed failed"
+ sed -i -e '30 d' -e '32 d' src/output.c || die "sed failed"
+
+}
+
+src_configure() {
+ econf \
+ $(use_with pvm pvm3) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README
+ cd doc
+ dodoc manual.pdf modules.pdf modules2.pdf morphix.pdf
+}