summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-05 00:28:41 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-05 00:28:41 +0200
commit0eae9ea80ef4b1b9dd6088892cb40357abf4b4a0 (patch)
tree89cd3e5b7b03c9436f30b405f6db324719a5be18 /app-misc/tek/files
parentapp-editors/xmlcopyeditor: Port to EAPI 7 (diff)
downloadgentoo-0eae9ea80ef4b1b9dd6088892cb40357abf4b4a0.tar.gz
gentoo-0eae9ea80ef4b1b9dd6088892cb40357abf4b4a0.tar.bz2
gentoo-0eae9ea80ef4b1b9dd6088892cb40357abf4b4a0.zip
app-misc/tek: Port to EAPI 7
Closes: https://bugs.gentoo.org/734252 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc/tek/files')
-rw-r--r--app-misc/tek/files/tek-1.3.0-makefile.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-misc/tek/files/tek-1.3.0-makefile.patch b/app-misc/tek/files/tek-1.3.0-makefile.patch
new file mode 100644
index 000000000000..b04985235e49
--- /dev/null
+++ b/app-misc/tek/files/tek-1.3.0-makefile.patch
@@ -0,0 +1,25 @@
+--- a/Makefile
++++ b/Makefile
+@@ -15,11 +15,10 @@
+
+ SOURCES=gui.cpp ihex.cpp usb.cpp
+
+-CXXFLAGS=-O2 -std=c++11
++CXXFLAGS+=-std=c++11
+
+ tek.lin: $(patsubst %.cpp,%-lin.o,$(SOURCES))
+- $(LIN_CXX) $(CXXFLAGS) $^ `$(LIN_WXCONFIG) --libs` -lusb-1.0 -o $@
+- $(LIN_STRIP) -s $@
++ $(CXX) $(LDFLAGS) $^ `$(WX_CONFIG) --libs` -lusb-1.0 -o $@ $(LIBS)
+
+ tek.mac: $(patsubst %.cpp,%-mac.o,$(SOURCES))
+ $(OSX_CXX) $(CXXFLAGS) $^ `$(OSX_WXCONFIG) --libs --static` -lusb-1.0 -o $@ -v
+@@ -30,7 +29,7 @@
+ $(WIN_STRIP) -s $@
+
+ %-lin.o: %.cpp
+- $(LIN_CXX) -c $(CXXFLAGS) `$(LIN_WXCONFIG) --cxxflags` $(filter %.cpp,$^) -o $@
++ $(CXX) -c $(CXXFLAGS) $(CPPFLAGS) `$(WX_CONFIG) --cxxflags` $(filter %.cpp,$^) -o $@
+
+ %-win.o: %.cpp
+ $(WIN_CXX) -c $(CXXFLAGS) `$(WIN_WXCONFIG) --cxxflags` $(filter %.cpp,$^) -o $@