summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-02-29 20:13:10 -0800
committerZac Medico <zmedico@gentoo.org>2016-02-29 20:19:48 -0800
commit6254346b61b1608969d3a2e78e934def15adfb86 (patch)
treec133fdf1cf0be03a03931d1f374bb3988bb5d6f4 /app-misc/tmux/tmux-9999.ebuild
parentx11-misc/dmenu: Tweak Gentoo patch. (diff)
downloadgentoo-6254346b61b1608969d3a2e78e934def15adfb86.tar.gz
gentoo-6254346b61b1608969d3a2e78e934def15adfb86.tar.bz2
gentoo-6254346b61b1608969d3a2e78e934def15adfb86.zip
app-misc/tmux: fix 9999 ebuild breakage for bug 574592
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-misc/tmux/tmux-9999.ebuild')
-rw-r--r--app-misc/tmux/tmux-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-misc/tmux/tmux-9999.ebuild b/app-misc/tmux/tmux-9999.ebuild
index d71fba04d744..577675cb612a 100644
--- a/app-misc/tmux/tmux-9999.ebuild
+++ b/app-misc/tmux/tmux-9999.ebuild
@@ -10,7 +10,8 @@ inherit autotools-utils git-r3 bash-completion-r1 flag-o-matic versionator
DESCRIPTION="Terminal multiplexer"
HOMEPAGE="http://tmux.github.io/"
-SRC_URI=""
+SRC_URI="https://raw.githubusercontent.com/przepompownia/tmux-bash-completion/678a27616b70c649c6701cae9cd8c92b58cc051b/completions/tmux -> tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b
+vim-syntax? ( https://raw.githubusercontent.com/keith/tmux.vim/95f6126c187667cc7f9c573c45c3b356cf69f4ca/syntax/tmux.vim -> tmux.vim-95f6126c187667cc7f9c573c45c3b356cf69f4ca )"
EGIT_REPO_URI="https://github.com/tmux/tmux.git"
LICENSE="ISC"
@@ -61,14 +62,14 @@ src_configure() {
src_install() {
autotools-utils_src_install
- newbashcomp examples/bash_completion_tmux.sh ${PN}
+ newbashcomp "${DISTDIR}/tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b" ${PN}
docinto examples
- dodoc examples/*.conf
+ dodoc example_tmux.conf
if use vim-syntax; then
insinto /usr/share/vim/vimfiles/syntax
- doins examples/tmux.vim
+ newins "${DISTDIR}/tmux.vim-95f6126c187667cc7f9c573c45c3b356cf69f4ca" tmux.vim
insinto /usr/share/vim/vimfiles/ftdetect
doins "${FILESDIR}"/tmux.vim