summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-08 00:44:37 +0100
committerSam James <sam@gentoo.org>2022-06-08 00:45:01 +0100
commit382ee61c3dcfd9ec419d2ec78fc1315a3c0611bd (patch)
tree2a7ec795b86b2ddd131a6a754ad897d969803caa /app-misc/tmux
parentsys-apps/openrc: sync live (diff)
downloadgentoo-382ee61c3dcfd9ec419d2ec78fc1315a3c0611bd.tar.gz
gentoo-382ee61c3dcfd9ec419d2ec78fc1315a3c0611bd.tar.bz2
gentoo-382ee61c3dcfd9ec419d2ec78fc1315a3c0611bd.zip
app-misc/tmux: add 3.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/tmux')
-rw-r--r--app-misc/tmux/Manifest1
-rw-r--r--app-misc/tmux/tmux-3.3.ebuild83
-rw-r--r--app-misc/tmux/tmux-9999.ebuild33
3 files changed, 105 insertions, 12 deletions
diff --git a/app-misc/tmux/Manifest b/app-misc/tmux/Manifest
index bb1858a63910..9ac29929b4a8 100644
--- a/app-misc/tmux/Manifest
+++ b/app-misc/tmux/Manifest
@@ -1,3 +1,4 @@
DIST tmux-3.1c.tar.gz 561323 BLAKE2B c6f688a854e128acffa140321a5dd00e4ca090ff79c7cbff15febbca6da9f7626c675fe1820b344637ff0fbe94ae6d0da7f111880ce5d74f97c4b6a90ceef802 SHA512 aad2e6457dd350369f245f711f1936a575d0588b72e660d10e7abc7d373da0d322903b451ad00b96a3e0e6847ca855673da6a4c5447cea91fa756edd23659397
DIST tmux-3.2a.tar.gz 648394 BLAKE2B 94527d4d1016caddab170b5bbfd181514768474898314241fb65a53a1f5ae94863bacedf90a7543690c115d15295960dfab4d5ba2ce31cd105585a73fb9b82d1 SHA512 6e52c7f5d03b2c8b8c4c8caac092a166956ba97334b426f2823d74dc5849a1d31a80145924f641f69dd2c244809e9350d9bd7070897fa2e3e1f9f086f9b2f365
+DIST tmux-3.3.tar.gz 677501 BLAKE2B 7e5b66d6d294c580d86f4f8729f867277e00f401dfa2a4b4c5dd5bd08c1e9884122340cbebfb37f56c67c65e940667f5b79b638f20f05282c434f7b3641ad003 SHA512 2988ccef62337dee0a22579868608b611ce17e2160358a9ba4cc3a353fd1e6b1fea87584ceeed885f986b1786aac1b681c71bdf6a48ed4953809093280b38c09
DIST tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b 458 BLAKE2B 04143e6d1cfbbd467f1656f949363cb7a4a3e16e9b3cf56b8b0423babe56276abee2622964cb490005fc76d1cbe12201fb1a6446a6f860c2cc1ff3c9bd5fc496 SHA512 fe0aca7d03067af87e0788a2fa902c7ef5500ba72295cb63c5a1814534a008c224256d7f890ac1af6d17f3734b45148765e1632f075e284c453185df2927b979
diff --git a/app-misc/tmux/tmux-3.3.ebuild b/app-misc/tmux/tmux-3.3.ebuild
new file mode 100644
index 000000000000..0ee80bc4dec7
--- /dev/null
+++ b/app-misc/tmux/tmux-3.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="https://tmux.github.io/"
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ SRC_URI="https://raw.githubusercontent.com/przepompownia/tmux-bash-completion/678a27616b70c649c6701cae9cd8c92b58cc051b/completions/tmux -> tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b"
+ EGIT_REPO_URI="https://github.com/tmux/tmux.git"
+else
+ SRC_URI="https://github.com/tmux/tmux/releases/download/${PV}/${P/_/-}.tar.gz"
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+ fi
+ S="${WORKDIR}/${P/_/-}"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="debug selinux systemd utempter vim-syntax"
+
+DEPEND="
+ dev-libs/libevent:=
+ sys-libs/ncurses:=
+ systemd? ( sys-apps/systemd:= )
+ utempter? ( sys-libs/libutempter )
+ kernel_Darwin? ( dev-libs/libutf8proc:= )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ virtual/yacc
+"
+
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-screen )
+ vim-syntax? ( app-vim/vim-tmux )
+"
+
+DOCS=( CHANGES README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4-flags.patch
+)
+
+src_prepare() {
+ # bug 438558
+ # 1.7 segfaults when entering copy mode if compiled with -Os
+ replace-flags -Os -O2
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc
+ $(use_enable debug)
+ $(use_enable systemd)
+ $(use_enable utempter)
+
+ # For now, we only expose this for macOS, because
+ # upstream strongly encourage it. I'm not sure it's
+ # needed on Linux right now.
+ $(use_enable kernel_Darwin utf8proc)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ einstalldocs
+
+ dodoc example_tmux.conf
+ docompress -x /usr/share/doc/${PF}/example_tmux.conf
+}
diff --git a/app-misc/tmux/tmux-9999.ebuild b/app-misc/tmux/tmux-9999.ebuild
index 9e9fa7c5e753..0ee80bc4dec7 100644
--- a/app-misc/tmux/tmux-9999.ebuild
+++ b/app-misc/tmux/tmux-9999.ebuild
@@ -1,31 +1,34 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools flag-o-matic
DESCRIPTION="Terminal multiplexer"
HOMEPAGE="https://tmux.github.io/"
-if [[ "${PV}" == 9999 ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
SRC_URI="https://raw.githubusercontent.com/przepompownia/tmux-bash-completion/678a27616b70c649c6701cae9cd8c92b58cc051b/completions/tmux -> tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b"
EGIT_REPO_URI="https://github.com/tmux/tmux.git"
else
- SRC_URI="https://github.com/tmux/tmux/releases/download/$(ver_cut 1-2)/${P/_/-}.tar.gz"
- [[ "${PV}" == *_rc* ]] || \
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+ SRC_URI="https://github.com/tmux/tmux/releases/download/${PV}/${P/_/-}.tar.gz"
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+ fi
S="${WORKDIR}/${P/_/-}"
fi
LICENSE="ISC"
SLOT="0"
-IUSE="debug selinux utempter vim-syntax"
+IUSE="debug selinux systemd utempter vim-syntax"
DEPEND="
- dev-libs/libevent:0=
- sys-libs/ncurses:0=
+ dev-libs/libevent:=
+ sys-libs/ncurses:=
+ systemd? ( sys-apps/systemd:= )
utempter? ( sys-libs/libutempter )
+ kernel_Darwin? ( dev-libs/libutf8proc:= )
"
BDEPEND="
@@ -36,14 +39,13 @@ BDEPEND="
RDEPEND="
${DEPEND}
selinux? ( sec-policy/selinux-screen )
- vim-syntax? ( app-vim/vim-tmux )"
+ vim-syntax? ( app-vim/vim-tmux )
+"
DOCS=( CHANGES README )
PATCHES=(
- "${FILESDIR}/${PN}-2.4-flags.patch"
-
- # upstream fixes (can be removed with next version bump)
+ "${FILESDIR}"/${PN}-2.4-flags.patch
)
src_prepare() {
@@ -59,8 +61,15 @@ src_configure() {
local myeconfargs=(
--sysconfdir="${EPREFIX}"/etc
$(use_enable debug)
+ $(use_enable systemd)
$(use_enable utempter)
+
+ # For now, we only expose this for macOS, because
+ # upstream strongly encourage it. I'm not sure it's
+ # needed on Linux right now.
+ $(use_enable kernel_Darwin utf8proc)
)
+
econf "${myeconfargs[@]}"
}