summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-02-16 15:47:50 -0800
committerPatrick McLean <chutzpah@gentoo.org>2024-02-16 15:47:50 -0800
commit22aeaab8b9724accdb43ea66fff1d48e25d08e2c (patch)
tree7a77cb82c3d665b62df17e3b607705b0dc1c0cdb /app-misc/tmuxp
parentdev-python/libtmux: add 0.30.2 (diff)
downloadgentoo-22aeaab8b9724accdb43ea66fff1d48e25d08e2c.tar.gz
gentoo-22aeaab8b9724accdb43ea66fff1d48e25d08e2c.tar.bz2
gentoo-22aeaab8b9724accdb43ea66fff1d48e25d08e2c.zip
app-misc/tmuxp: Revbump, relax libtmux dep
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/tmuxp')
-rw-r--r--app-misc/tmuxp/tmuxp-1.38.0-r1.ebuild (renamed from app-misc/tmuxp/tmuxp-1.38.0.ebuild)9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-misc/tmuxp/tmuxp-1.38.0.ebuild b/app-misc/tmuxp/tmuxp-1.38.0-r1.ebuild
index cba7517555f5..728768efecb0 100644
--- a/app-misc/tmuxp/tmuxp-1.38.0.ebuild
+++ b/app-misc/tmuxp/tmuxp-1.38.0-r1.ebuild
@@ -17,7 +17,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
RDEPEND="
>=app-misc/tmux-3.0a
- =dev-python/libtmux-0.30.1*[${PYTHON_USEDEP}]
+ =dev-python/libtmux-0.30*[${PYTHON_USEDEP}]
>=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
>=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
"
@@ -38,6 +38,13 @@ EPYTEST_DESELECT=(
distutils_enable_tests pytest
+python_prepare_all() {
+ sed -r -e 's:libtmux = "~[0-9.]+":libtmux = "~0.30":' \
+ -i pyproject.toml || die
+
+ distutils-r1_python_prepare_all
+}
+
python_test() {
SHELL="/bin/bash" epytest tests
}