summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-08-21 09:39:11 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-08-21 09:39:24 -0700
commit27ec4f2ea7f9805a4b14c51b1ee09827a9ffa6a2 (patch)
tree50f32b8e912ff0e0e6a7d2da64b38e383cd4d990 /app-misc/tmuxp
parentdev-python/libtmux: add 0.23.0 (diff)
downloadgentoo-27ec4f2ea7f9805a4b14c51b1ee09827a9ffa6a2.tar.gz
gentoo-27ec4f2ea7f9805a4b14c51b1ee09827a9ffa6a2.tar.bz2
gentoo-27ec4f2ea7f9805a4b14c51b1ee09827a9ffa6a2.zip
app-misc/tmuxp: add 1.29.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/tmuxp')
-rw-r--r--app-misc/tmuxp/Manifest1
-rw-r--r--app-misc/tmuxp/tmuxp-1.29.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/tmuxp/Manifest b/app-misc/tmuxp/Manifest
index ebc218b1305d..f681bbe2cd07 100644
--- a/app-misc/tmuxp/Manifest
+++ b/app-misc/tmuxp/Manifest
@@ -1,3 +1,4 @@
DIST tmuxp-1.27.0.tar.gz 862056 BLAKE2B baad339bc59498d26911507f29de38d55991515e03123edc8dca10159fed1492c1ffe37cf45d6d04ffc73134e0ee312c0ace2ffc53ba9cae258239746169e416 SHA512 a9c450c40a40c284c609011d5e47b12ed1a9b1d5c4036b887df7fd75a3bb6263847c459a7e61fc9dcdb463a3ac20de6ac9038b1559369a5f36641ab0baee755d
DIST tmuxp-1.27.1.tar.gz 861380 BLAKE2B b57d7f4f5c23d1df71abd310b02535c8da7971df4473a3ff2c5feffb2967bd7b0c00e47e45bc04bf56b9503d17b55786b9abfeabec4f6d33989a2f58c5ba49d5 SHA512 3e3d9405a77fe03d2a249bad4ef215982d9135e85dc58899a337d0a3f6d76a4e9f155f5dc37993f5e57955411928ce921ce1c1f1ee7c39f0939d2831a3d600be
DIST tmuxp-1.28.1.tar.gz 859970 BLAKE2B 5ea35b12a20f744f889ff6b35195144f195232d52fc67fb7128f2eb9205aea0e2a695f5d06d6df97a9ad8ea93bda37f225b1236c97e8b9f29c490cc526d4e383 SHA512 3023bc780bf4deffa4b1d7898e7cdfe6ba6611511a75b7559a7ca3898d7bc7dff2b5806016f4d88fa0acc8bb57606d0b5231fc26dae7e33990284cdd1dc836df
+DIST tmuxp-1.29.0.tar.gz 861381 BLAKE2B 37f99d74a9c08bd4f348ec4cefe4197f1d5d3c2573a493be0b1ab22becd8128dcc38f4c47dfd14e61499dd99dad87349527ed06969438f7ee7d22658485e7cdb SHA512 b83f9a92622bd9b8e752d38bc629e484378db9ee7a7ac6cbc67acb37ce98b8fce7ead23bac997367e83f22aca3b75a950a068b33df654cae9403c76390893209
diff --git a/app-misc/tmuxp/tmuxp-1.29.0.ebuild b/app-misc/tmuxp/tmuxp-1.29.0.ebuild
new file mode 100644
index 000000000000..6dd61df9fce6
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.29.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ =dev-python/libtmux-0.22.1*[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+EPYTEST_DESELECT=(
+ # test doesn't get along with sandbox
+ "tests/cli/test_load.py::test_load_zsh_autotitle_warning"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ SHELL="/bin/bash" epytest tests
+}