summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-02-07 10:22:03 -0800
committerPatrick McLean <chutzpah@gentoo.org>2024-02-07 10:22:03 -0800
commit7aa6946c8c12bd8378c2996422930114011921ab (patch)
treed050f8842026965c2626346948c4b644a3d0462a /app-misc/tmuxp
parentdev-python/libtmux: add 0.27.0 (diff)
downloadgentoo-7aa6946c8c12bd8378c2996422930114011921ab.tar.gz
gentoo-7aa6946c8c12bd8378c2996422930114011921ab.tar.bz2
gentoo-7aa6946c8c12bd8378c2996422930114011921ab.zip
app-misc/tmuxp: add 1.36.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/tmuxp')
-rw-r--r--app-misc/tmuxp/Manifest1
-rw-r--r--app-misc/tmuxp/tmuxp-1.36.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/tmuxp/Manifest b/app-misc/tmuxp/Manifest
index 9249fb4247a5..ee7d63b19bb1 100644
--- a/app-misc/tmuxp/Manifest
+++ b/app-misc/tmuxp/Manifest
@@ -3,3 +3,4 @@ DIST tmuxp-1.27.1.tar.gz 861380 BLAKE2B b57d7f4f5c23d1df71abd310b02535c8da7971df
DIST tmuxp-1.30.1.tar.gz 862947 BLAKE2B b80c85df49c267a076d4f073bb83e4b0823ec140324e5689c0300dc2a854c03cb313544b2265ac84b2ac6bd8253b30bfec2cfed568311274fd65fa68221d9c9e SHA512 b9eca20dce6aa6a61807225a40a343d01d3ce767c613c8d98eec25c6037bde1b4859abfd3ac43c2f7843316c2beb995d68e4c4af9d4949e854da4b71919106e8
DIST tmuxp-1.31.0.tar.gz 862999 BLAKE2B 56634c8686701d6081db19bf659012df54f4b393fc60dc085c4bd1c460e85d8910ce55651bc6207c4c72b5c8a4c78548145c4b8076bd674942f3e72b67b0edae SHA512 32ea719798ca16d55090ab8ea3e54b03e9136b7bcd4b9c74f77c73c703479a435468f31b1761855b17710c5df9eadde094d56166698217f1ffd6efba42607824
DIST tmuxp-1.32.1.tar.gz 863062 BLAKE2B c9c095e43030f22a85ea7dc91bbf21e91d9eaf5c9b653f5c7a0cc49e6246e1af13e4e83f7df893665f455d5d7de1326c62df05ee7fc3f573dd58a746fdce1dda SHA512 096831f3da4b3ead1ef8dda20248fde334f6c0fd14661823db163a234afbad275b8b54791cc358365454aedf8277b8956bd3c7d27a36f4978982617462992517
+DIST tmuxp-1.36.0.tar.gz 869804 BLAKE2B d42abcc831a00cabdd9ae315d86cfd159b5c26b4b68e2fa3fd13c37150cf0fdf542c6216786b72411b31acccff8094f5a2f119e7ebc889af8f659db3aec24a9a SHA512 569d7873d7d46d101bfff034685ac547e04256c0d2146c11ed605971b59a4e0842f441a3c4974a0b8e5f8eeec84f5cd7132f3ef8ada5bdbaa2241a89cb7e2776
diff --git a/app-misc/tmuxp/tmuxp-1.36.0.ebuild b/app-misc/tmuxp/tmuxp-1.36.0.ebuild
new file mode 100644
index 000000000000..58ddbbfaba49
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.36.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ =dev-python/libtmux-0.27.0*[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/typing-extensions-4.0.1[${PYTHON_USEDEP}]' 3.{9..10})
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+EPYTEST_DESELECT=(
+ # test doesn't get along with sandbox
+ "tests/cli/test_load.py::test_load_zsh_autotitle_warning"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ SHELL="/bin/bash" epytest tests
+}