summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-08-01 12:27:37 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-08-01 12:27:44 -0700
commit8e3c95e355fa72c7172d6180952b318074d3b8e6 (patch)
treef25ec256649a2efd846a81f2290dbeec61a4c628 /app-misc/tmuxp
parentdev-python/jsonschema: Keyword 4.9.0 x86, #862825 (diff)
downloadgentoo-8e3c95e355fa72c7172d6180952b318074d3b8e6.tar.gz
gentoo-8e3c95e355fa72c7172d6180952b318074d3b8e6.tar.bz2
gentoo-8e3c95e355fa72c7172d6180952b318074d3b8e6.zip
app-misc/tmuxp: add 1.12.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/tmuxp')
-rw-r--r--app-misc/tmuxp/Manifest1
-rw-r--r--app-misc/tmuxp/tmuxp-1.12.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/tmuxp/Manifest b/app-misc/tmuxp/Manifest
index f06e01b7a427..f39378b48fdf 100644
--- a/app-misc/tmuxp/Manifest
+++ b/app-misc/tmuxp/Manifest
@@ -1,2 +1,3 @@
DIST tmuxp-1.11.1.tar.gz 830701 BLAKE2B 37f23abf16ef78b27f04e6af9c95990d39173e62fb4ab2c898fb45075242ee2761e0c69b8f391cb59d4fd2ccee8d157650718450814ebd06716c54afd0e59338 SHA512 23cf70cffa86e8478f39661951ca468b09a8caa3e7c8a9114011a5a5440fa817c3425b38cbf00b9b7966ac1449094d101f74a450e77c153e9a1d9ca73c49e856
+DIST tmuxp-1.12.0.tar.gz 839506 BLAKE2B 83111ee0c24611f762ddd1c22f81f164c29fd89d9e581483a6cc826f65e943228af5aea6779b3f715ea911631ccfe0ef8027a2e9a4db658fd2c66bdcc46195ee SHA512 e6c24ae0be116a627902628ea08efc3c4e33436ecc86007fa3906f4e3eb22fa3b7cc275eeec0ca336ad0d6a18d897a1a1a6f962b8219ee58faad57b63601335b
DIST tmuxp-1.9.4.tar.gz 821650 BLAKE2B 34454919e811bc4901dcb570046b45d481934ab36f9b8f50753972fe6545ca9e487b2f04ee818c4b54eea01181c62efb1f5262ab033f2fc92c3cee3828d16bf4 SHA512 ecf113011231a03998b3be2d146f7e6c6cc2ccfc36af59b88d51e09726259c92dc4360bde569fba13ca8d81eb9639f85b45cd5f4b50d70d347e3237e396ea446
diff --git a/app-misc/tmuxp/tmuxp-1.12.0.ebuild b/app-misc/tmuxp/tmuxp-1.12.0.ebuild
new file mode 100644
index 000000000000..e4488877fe08
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.12.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ >=dev-python/kaptan-0.5.10[${PYTHON_USEDEP}]
+ ~dev-python/libtmux-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ dev-python/pathspec[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/tmuxp-1.7.2-tests.patch"
+ "${FILESDIR}/tmuxp-1.9.2-tests.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ SHELL="/bin/bash" epytest
+}