summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-02-13 01:34:01 +0000
committerMatt Turner <mattst88@gentoo.org>2021-03-24 12:06:56 -0400
commit956d31bbd2b5152717da12cde6f6c06d5c7da510 (patch)
treeb17dddc4ff39c8f3b584fa7cea14dc1369e6714d /app-misc/tpconfig/tpconfig-3.1.3-r3.ebuild
parentapp-misc/g15stats: revbump for d-m-i (diff)
downloadgentoo-956d31bbd2b5152717da12cde6f6c06d5c7da510.tar.gz
gentoo-956d31bbd2b5152717da12cde6f6c06d5c7da510.tar.bz2
gentoo-956d31bbd2b5152717da12cde6f6c06d5c7da510.zip
app-misc/tpconfig: revbump for d-m-i
Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-misc/tpconfig/tpconfig-3.1.3-r3.ebuild')
-rw-r--r--app-misc/tpconfig/tpconfig-3.1.3-r3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-misc/tpconfig/tpconfig-3.1.3-r3.ebuild b/app-misc/tpconfig/tpconfig-3.1.3-r3.ebuild
new file mode 100644
index 000000000000..b80c3d28c2fd
--- /dev/null
+++ b/app-misc/tpconfig/tpconfig-3.1.3-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Touchpad config for ALPS and Synaptics TPs. Controls tap/click behaviour"
+HOMEPAGE="http://www.compass.com/synaptics/"
+SRC_URI="http://www.compass.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ einstalldocs
+ dobin "${PN}"
+ newinitd "${FILESDIR}"/"${PN}-r1" "${PN}"
+ newconfd "${FILESDIR}"/"${PN}.conf" "${PN}"
+}