summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-09-06 15:53:37 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-09-06 16:01:37 -0400
commit39b81ac611f10dc2a7adeafcec64720aba99f3e3 (patch)
tree49ed8def7ea4728c186adcf1b4409a623f6c7ae3 /app-misc/trash-cli/trash-cli-0.17.1.14_p20170816.ebuild
parentpackage.mask: unmask aiohttp-3 (diff)
downloadgentoo-39b81ac611f10dc2a7adeafcec64720aba99f3e3.tar.gz
gentoo-39b81ac611f10dc2a7adeafcec64720aba99f3e3.tar.bz2
gentoo-39b81ac611f10dc2a7adeafcec64720aba99f3e3.zip
app-misc/trash-cli: bump to 0.17.1.14_p20170816
Patch by Alex Xu Closes: https://bugs.gentoo.org/643488 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-misc/trash-cli/trash-cli-0.17.1.14_p20170816.ebuild')
-rw-r--r--app-misc/trash-cli/trash-cli-0.17.1.14_p20170816.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/trash-cli/trash-cli-0.17.1.14_p20170816.ebuild b/app-misc/trash-cli/trash-cli-0.17.1.14_p20170816.ebuild
new file mode 100644
index 000000000000..769a796bf485
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.17.1.14_p20170816.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+
+inherit distutils-r1 vcs-snapshot
+
+GIT_REF=5abecd53e1d84f2a5fd3fc60d2f5d71e518826c5
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${GIT_REF}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests -v || die
+}