summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Leupold <tobias.leupold@gmx.de>2018-10-07 16:15:06 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-07 19:18:10 +0200
commit7a92c1ba02485e71c659606483b103b2905f4836 (patch)
tree45f1f9ff39fb0d1ace806193669f303a24cb2ee3 /app-misc/vcontrold/vcontrold-0.98.6.ebuild
parentsci-calculators/units: Stable for AMD64 HPPA x86 too. (diff)
downloadgentoo-7a92c1ba02485e71c659606483b103b2905f4836.tar.gz
gentoo-7a92c1ba02485e71c659606483b103b2905f4836.tar.bz2
gentoo-7a92c1ba02485e71c659606483b103b2905f4836.zip
Version bump: app-misc/vcontrold-0.98.6
Signed-off-by: Tobias Leupold <tobias.leupold@gmx.de> Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9989
Diffstat (limited to 'app-misc/vcontrold/vcontrold-0.98.6.ebuild')
-rw-r--r--app-misc/vcontrold/vcontrold-0.98.6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/vcontrold/vcontrold-0.98.6.ebuild b/app-misc/vcontrold/vcontrold-0.98.6.ebuild
new file mode 100644
index 000000000000..cd6ff144ee01
--- /dev/null
+++ b/app-misc/vcontrold/vcontrold-0.98.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Daemon for communication with Viessmann Vito heatings"
+HOMEPAGE="https://github.com/openv/vcontrold/"
+SRC_URI="https://github.com/openv/vcontrold/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+man +vclient vsim"
+
+RDEPEND="dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ man? ( dev-python/docutils )"
+
+src_prepare() {
+ sed "s/@VERSION@/${PV}/" "src/version.h.in" \
+ > "src/version.h" || die "Setting version failed"
+ eapply "${FILESDIR}"/man_generation.patch
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DMANPAGES="$(usex man)"
+ -DVCLIENT="$(usex vclient)"
+ -DVSIM="$(usex vsim)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doinitd "${FILESDIR}/vcontrold"
+ insinto /etc/vcontrold/
+ doins -r xml
+}