summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-28 14:50:40 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-28 16:32:29 -0400
commit9b4ec85863c2f21de0a48ee297c293173474d42c (patch)
treecc9c194c1e6221a85117d740079ed0f6008e476f /app-misc/worker/worker-3.8.3.ebuild
parentdev-java/java-sdk-docs: Version bump to 1.8.0.102 (diff)
downloadgentoo-9b4ec85863c2f21de0a48ee297c293173474d42c.tar.gz
gentoo-9b4ec85863c2f21de0a48ee297c293173474d42c.tar.bz2
gentoo-9b4ec85863c2f21de0a48ee297c293173474d42c.zip
app-misc/worker: new version 3.8.3.
Gentoo-Bug: 515048 Package-Manager: portage-2.2.28
Diffstat (limited to 'app-misc/worker/worker-3.8.3.ebuild')
-rw-r--r--app-misc/worker/worker-3.8.3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-misc/worker/worker-3.8.3.ebuild b/app-misc/worker/worker-3.8.3.ebuild
new file mode 100644
index 000000000000..65017cdb6a79
--- /dev/null
+++ b/app-misc/worker/worker-3.8.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Worker Filemanager: Amiga Directory Opus 4 clone"
+HOMEPAGE="http://www.boomerangsworld.de/cms/worker/"
+SRC_URI="http://www.boomerangsworld.de/cms/worker/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="avfs debug dbus examples libnotify lua +magic xinerama xft"
+
+RDEPEND="x11-libs/libX11
+ avfs? ( >=sys-fs/avfs-0.9.5 )
+ dbus? ( dev-libs/dbus-glib )
+ lua? ( dev-lang/lua:0 )
+ magic? ( sys-apps/file )
+ xft? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README README_LARGEFILES THANKS )
+
+src_configure() {
+ # there is no ./configure flag to disable libXinerama support
+ export ac_cv_lib_Xinerama_XineramaQueryScreens=$(usex xinerama)
+ econf \
+ --without-hal \
+ --enable-utf8 \
+ $(use_with avfs) \
+ $(use_with dbus) \
+ $(use_enable debug) \
+ $(use_enable libnotify inotify) \
+ $(use_enable lua) \
+ $(use_with magic libmagic) \
+ $(use_enable xft)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ docinto examples
+ dodoc examples/config-*
+ fi
+}