summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-09-15 14:54:21 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-09-15 14:54:21 +0200
commitf93c131422212a9825b81d4214a8aa98ccb7983f (patch)
tree2338902873fe778fe4121d18a48f0f3bbb6c7334 /app-misc/yq/yq-2.3.0.ebuild
parentdev-python/docutils-glep: Add a live ebuild for the revived project (diff)
downloadgentoo-f93c131422212a9825b81d4214a8aa98ccb7983f.tar.gz
gentoo-f93c131422212a9825b81d4214a8aa98ccb7983f.tar.bz2
gentoo-f93c131422212a9825b81d4214a8aa98ccb7983f.zip
app-misc/yq: Version bump to 2.3.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-misc/yq/yq-2.3.0.ebuild')
-rw-r--r--app-misc/yq/yq-2.3.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-misc/yq/yq-2.3.0.ebuild b/app-misc/yq/yq-2.3.0.ebuild
new file mode 100644
index 000000000000..2ead45746ee3
--- /dev/null
+++ b/app-misc/yq/yq-2.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command-line YAML processor - jq wrapper for YAML documents"
+HOMEPAGE="https://yq.readthedocs.io/ https://github.com/kislyuk/yq/ https://pypi.python.org/pypi/yq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-misc/jq
+ >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ./test/test.py || die
+}