summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-27 07:06:02 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-27 07:22:36 +0200
commit02951365a6fbefd3f05f64a8929c1588ff15d0e2 (patch)
treeb1464f32b859c0b742b801a9ca22551e69ee7cb7 /app-misc
parentapp-misc/sphinx: cleanup (diff)
downloadgentoo-02951365a6fbefd3f05f64a8929c1588ff15d0e2.tar.gz
gentoo-02951365a6fbefd3f05f64a8929c1588ff15d0e2.tar.bz2
gentoo-02951365a6fbefd3f05f64a8929c1588ff15d0e2.zip
app-misc/sphinx: add mariadb USE flag
Update mysql dependency to use mysql-connector-c and add USE flag for mariadb to use mariadb-connector-c. These options are mutually exclusive. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/sphinx/metadata.xml1
-rw-r--r--app-misc/sphinx/sphinx-2.2.11-r1.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/app-misc/sphinx/metadata.xml b/app-misc/sphinx/metadata.xml
index 80a8842e3c97..397dd2466c73 100644
--- a/app-misc/sphinx/metadata.xml
+++ b/app-misc/sphinx/metadata.xml
@@ -6,6 +6,7 @@
</maintainer>
<use>
<flag name="id64">use 64-bit document and word IDs</flag>
+ <flag name="mariadb">Add mariadb database support</flag>
<flag name="re2">use the <pkg>dev-libs/re2</pkg> regular expression library</flag>
<flag name="stemmer">Enable language stemming support</flag>
</use>
diff --git a/app-misc/sphinx/sphinx-2.2.11-r1.ebuild b/app-misc/sphinx/sphinx-2.2.11-r1.ebuild
new file mode 100644
index 000000000000..32f06578cd75
--- /dev/null
+++ b/app-misc/sphinx/sphinx-2.2.11-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WANT_AUTOMAKE=1.15
+
+inherit eutils autotools toolchain-funcs
+
+#MY_P=${P/_/-}
+MY_P=${P}-release
+
+DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
+HOMEPAGE="http://www.sphinxsearch.com/"
+SRC_URI="http://sphinxsearch.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug +id64 mariadb mysql odbc postgres re2 stemmer syslog xml"
+
+REQUIRED_USE="mysql? ( !mariadb ) mariadb? ( !mysql )"
+
+RDEPEND="
+ mysql? ( dev-db/mysql-connector-c )
+ mariadb? ( dev-db/mariadb-connector-c )
+ postgres? ( dev-db/postgresql:* )
+ odbc? ( dev-db/unixODBC )
+ re2? ( dev-libs/re2 )
+ stemmer? ( dev-libs/snowball-stemmer )
+ xml? ( dev-libs/expat )
+ virtual/libiconv"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.1_beta-darwin8.patch
+
+ # drop nasty hardcoded search path breaking Prefix
+ # We patch configure directly since otherwise we need to run
+ # eautoreconf twice and that causes problems, bug 425380
+ sed -i -e 's/\/usr\/local\//\/someplace\/nonexisting\//g' configure || die
+
+ if use mariadb ; then
+ sed -i -e 's/mysql_config/mariadb_config/g' configure || die
+ fi
+
+ # Fix QA compilation warnings.
+ sed -i -e '19i#include <string.h>' api/libsphinxclient/test.c || die
+
+ eapply_user
+
+ pushd api/libsphinxclient || die
+ eautoreconf
+ popd || die
+
+ # Drop bundled code to ensure building against system versions. We
+ # cannot remove libstemmer_c since configure updates its Makefile.
+ rm -rf libexpat libre2 || die
+}
+
+src_configure() {
+ # fix libiconv detection
+ use !elibc_glibc && export ac_cv_search_iconv=-liconv
+
+ local mysql_with
+ if use mysql || use mariadb ; then
+ mysql_with="--with-mysql"
+ else
+ mysql_with="--without-mysql"
+ fi
+
+ econf \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
+ $(use_enable id64) \
+ $(use_with debug) \
+ ${mysql_with} \
+ $(use_with odbc unixodbc) \
+ $(use_with postgres pgsql) \
+ $(use_with re2) \
+ $(use_with stemmer libstemmer) \
+ $(use_with syslog syslog) \
+ $(use_with xml libexpat )
+
+ cd api/libsphinxclient || die
+ econf STRIP=:
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" || die "emake failed"
+
+ emake -j 1 -C api/libsphinxclient || die "emake libsphinxclient failed"
+}
+
+src_test() {
+ # Tests require a live database and only work from the source
+ # directory.
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" -C api/libsphinxclient install || die "install libsphinxclient failed"
+
+ dodoc doc/*
+
+ dodir /var/lib/sphinx
+ dodir /var/log/sphinx
+
+ newinitd "${FILESDIR}"/searchd.rc searchd
+}