summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-02-12 10:50:52 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-02-12 10:50:59 +0100
commit06352707b330a6092113a0fcd213cfaf386a1e71 (patch)
treedc046fd9e4a9bd77efd38c3d4eebc818a5b68261 /app-misc
parentwww-misc/vdradmin-am: switch tmpfiles handling to tmpfiles.eclass (diff)
downloadgentoo-06352707b330a6092113a0fcd213cfaf386a1e71.tar.gz
gentoo-06352707b330a6092113a0fcd213cfaf386a1e71.tar.bz2
gentoo-06352707b330a6092113a0fcd213cfaf386a1e71.zip
app-misc/detox: Bump to version 1.4.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/detox/Manifest1
-rw-r--r--app-misc/detox/detox-1.4.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/detox/Manifest b/app-misc/detox/Manifest
index 1bd619315c0f..ba4b06824af1 100644
--- a/app-misc/detox/Manifest
+++ b/app-misc/detox/Manifest
@@ -1 +1,2 @@
DIST detox-1.2.0.tar.bz2 86118 BLAKE2B 2dbde6ebd98b59c18c60f99006731484dcbc698ab77b56991f2af94f4ad45da141046975af47b66242ff42d4e3a8bb3b515d4b70ba30f12cb1b8ceea5832f52a SHA512 48c0060ed0538c26aeba444bf327f1e52ea47d0e696577deeb43304dfb960ee5abe984651948bfc67c51d7f15f9051df2a208acfe53a5778a7471460e87f639a
+DIST detox-1.4.0.tar.gz 106361 BLAKE2B 5993ded30282a16a81481885cdee41fe0b1c2ac34e5f389b53981e098d13acdfe367c7de462436fe3a4ee8ff86220f4c69d54a47c1122a0f39bde12c4d6ec908 SHA512 9486056b3b58dbb5ae16bc461586a997f8990ddb6e0db5ba561df862c16dfe926911fd09f065ef2578d39c3e3f1a267be201f865cf3f6b576c01910bda39cecb
diff --git a/app-misc/detox/detox-1.4.0.ebuild b/app-misc/detox/detox-1.4.0.ebuild
new file mode 100644
index 000000000000..ab367fc95870
--- /dev/null
+++ b/app-misc/detox/detox-1.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${PN}-${PV/_/-}"
+
+DESCRIPTION="Safely remove spaces and strange characters from filenames"
+HOMEPAGE="http://detox.sourceforge.net/ https://github.com/dharple/detox"
+SRC_URI="https://github.com/dharple/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+RDEPEND="
+ !dev-python/detox"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/bison
+"
+
+src_prepare() {
+ default
+ sed \
+ -e '/detoxrc.sample/d' \
+ -i Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ dodoc etc/${PN}rc.sample
+}