summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-12 20:01:49 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-12 20:01:49 +0200
commit0d921fb9c272d16408469d503a60a7a719bcab98 (patch)
treeebcca4a5d27c05cb822daa5cf17d1f7fcd57ad3a /app-misc
parentapp-misc/votrify: Bump to v4 (diff)
downloadgentoo-0d921fb9c272d16408469d503a60a7a719bcab98.tar.gz
gentoo-0d921fb9c272d16408469d503a60a7a719bcab98.tar.bz2
gentoo-0d921fb9c272d16408469d503a60a7a719bcab98.zip
app-misc/votrify: Bump to v5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/votrify/Manifest1
-rw-r--r--app-misc/votrify/votrify-5.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/votrify/Manifest b/app-misc/votrify/Manifest
index ec855c976143..409d9a85f16c 100644
--- a/app-misc/votrify/Manifest
+++ b/app-misc/votrify/Manifest
@@ -2,3 +2,4 @@ DIST votrify-1.tar.gz 6936 BLAKE2B 7c9a5668842c5b1783e5c8b2341d42aa21257b96a8221
DIST votrify-2.tar.gz 9095 BLAKE2B 801c9ad89f93349ce6ad0d9421e9a968a511d9699454c91cc713dd3a133c4f87666de3bc3905041999a5090eb5794d6ceed89aabc997e6950d2b5a4b4bb185cc SHA512 8c3795520d6ee5d34c8aa649a24309e30da8843bcddbfc8ff0b822eab5529a621d9fa475dc6714a6de0ed1d229d3a949870666967448a23036d28af5e7da00ab
DIST votrify-3.tar.gz 9153 BLAKE2B fdff14dd7332bd6688cb2d04d87e7cf0888aa881cac6a98961cc544182869b190ac8591545c773e7a14293ff0fac7efd646be3cc7f8d059a8e45b709051eae69 SHA512 bde636cb238e114814f1246f49c9b5f363d7c9255da4cf2f5da6cb8da19f1b970e0027b630f21b0166c73de770e5bc931b811c3326ccc790db6d1d873731ef9e
DIST votrify-4.tar.gz 9184 BLAKE2B 78149b3e53a830c405de70b0dff301eb4467489a59af8de76fade98eeeacc9ae78cc229db23eef26355579a9944917074419e2f38eb59eb0cae6d314985d0383 SHA512 1639fd6b6e96fb767088fb4b3be4d2d09cb0f6a12bdd745d610b6853ff2f585f8100523e92ee75d7800fe54cb42a5c716bbefe57d85395627e8c67d75e45aae1
+DIST votrify-5.tar.gz 9192 BLAKE2B 5df0ccd0b5a843b384e002c2bd1001df06cb5bcf039f10c689abeda07f1a05c545a917b0a42bd78c06c537eacca58ef7b4c2920a0fe6809f4450d4c98ee2fade SHA512 3d441eb42f860e4e571541300a04c1a52a01abbe20f76615adc1c9764bafbff35faf0f1dbe9f9267ad3c4dc0e4cb4bc715b87e2104cdef8997e7918ab834bb5d
diff --git a/app-misc/votrify/votrify-5.ebuild b/app-misc/votrify/votrify-5.ebuild
new file mode 100644
index 000000000000..278667874da3
--- /dev/null
+++ b/app-misc/votrify/votrify-5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit python-single-r1
+
+DESCRIPTION="Tool for community verification of Gentoo elections"
+HOMEPAGE="https://github.com/mgorny/votrify"
+SRC_URI="https://github.com/mgorny/votrify/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-misc/gentoo-elections"
+
+src_configure() {
+ # update default location for election scripts
+ sed -i -e "s^os.path.dirname(__file__)^'${EPREFIX}/usr/lib'^" \
+ votrify-make-confirmation || die
+
+ python_fix_shebang votrify-{make,verify}-*
+}
+
+make_wrappers() {
+ local election=${1}
+
+ newbin - "votrify-${election}-make" \
+ < <(sed -e "s^@ELECTION@^${election}^" \
+ votrify-wrapper-make.bash.in || die)
+ newbin - "votrify-${election}-verify" \
+ < <(sed -e "s^@ELECTION@^${election}^" \
+ votrify-wrapper-verify.bash.in || die)
+}
+
+src_install() {
+ dobin votrify-{make,verify}-*
+ make_wrappers council-201906
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "In order to interactively create confirmation for Council 2019 election:"
+ elog " votrify-council-201906-make"
+ elog
+ elog "In order to verify the results for Council 2019 election:"
+ elog " votrify-council-201906-verify"
+}