summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2022-08-20 22:19:00 -0700
committerJoonas Niilola <juippis@gentoo.org>2022-09-05 15:37:12 +0300
commit132ac86bb4809a600c09607997c700a9ffd097fe (patch)
tree951201ccbc9ff65d68c10a9bc3fb7976f005c776 /app-misc
parentdev-python/spyder: update optional plugins list (diff)
downloadgentoo-132ac86bb4809a600c09607997c700a9ffd097fe.tar.gz
gentoo-132ac86bb4809a600c09607997c700a9ffd097fe.tar.bz2
gentoo-132ac86bb4809a600c09607997c700a9ffd097fe.zip
app-misc/trash-cli: add 0.22.8.21
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Closes: https://github.com/gentoo/gentoo/pull/26938 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/trash-cli/Manifest1
-rw-r--r--app-misc/trash-cli/trash-cli-0.22.8.21.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/trash-cli/Manifest b/app-misc/trash-cli/Manifest
index 1578beac09fc..4098df1d8a0b 100644
--- a/app-misc/trash-cli/Manifest
+++ b/app-misc/trash-cli/Manifest
@@ -1 +1,2 @@
DIST trash-cli-0.22.4.16.tar.gz 78221 BLAKE2B 9eabecf5b4e787e1a413f4b05fb6c5592b4a5ec55e4a399c02c738e2ad62acaabc234217954262a79c85ad855535a2ca0d6f981b0ac86139f6c631519aeea936 SHA512 961e87ec361c405a45d02e6a4b7bf43493bca86cf3540a7235df459abd450762bcea4760acdfed0e5f276933ff0eb5b9f426ae0eecfde3e5830a8699fa99a19f
+DIST trash-cli-0.22.8.21.tar.gz 79315 BLAKE2B a4b0f3072d9a9091b90bec13e3a8208c58638f7dd054a788ba0126f8c803748c837dbf183513ca87a775d4efbed9e926603b2b3839f9f499963b774f59f06cd5 SHA512 9c8a40cd92c070dfcadfe2a4871c16a3cfc066568f0e079e11ff80aff53777335f1fec42245846bba04866a55ba9d11a2493950ccdcefcd7d98825508eb6ab6b
diff --git a/app-misc/trash-cli/trash-cli-0.22.8.21.ebuild b/app-misc/trash-cli/trash-cli-0.22.8.21.ebuild
new file mode 100644
index 000000000000..641302d9ab3e
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.22.8.21.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}