summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2023-01-19 23:24:39 -0800
committerViorel Munteanu <ceamac@gentoo.org>2023-02-08 15:05:49 +0200
commit1610f04351bc1c162b8592ba2a47d33a618aafe0 (patch)
tree2923d509cff5405b658f4142e2e99df07c92dc4e /app-misc
parentmedia-fonts/source-serif: add 4.005 (diff)
downloadgentoo-1610f04351bc1c162b8592ba2a47d33a618aafe0.tar.gz
gentoo-1610f04351bc1c162b8592ba2a47d33a618aafe0.tar.bz2
gentoo-1610f04351bc1c162b8592ba2a47d33a618aafe0.zip
app-misc/remind: add 04.02.02
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Bug: https://bugs.gentoo.org/889318 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/remind/Manifest1
-rw-r--r--app-misc/remind/files/remind-include-fix.patch11
-rw-r--r--app-misc/remind/remind-04.02.02.ebuild51
3 files changed, 63 insertions, 0 deletions
diff --git a/app-misc/remind/Manifest b/app-misc/remind/Manifest
index 9ef8530164ad..8ba8968c31f6 100644
--- a/app-misc/remind/Manifest
+++ b/app-misc/remind/Manifest
@@ -1,2 +1,3 @@
DIST remind-04.00.03.tar.bz2 390884 BLAKE2B 4f619ec902f76c5c4857ffa85428154ef6fe525cc97bbe92272f3abca3e8cdd39dd45d1c45c5f6e87f0d22dde500dd80629882bdbe93a6b97b5da96757b5af9c SHA512 41d61d267d99d787993cd5bf3889f1fe80f76a0cfe5a7e2d360eb7239a1b5a05b50b3b5cde30c50404813e723545eb805148ca2c6e540eb9aacbf5e8ffd64014
DIST remind-04.02.00.tar.bz2 408137 BLAKE2B 000528ffe8e65b0bd7049dd65b0e29f4588f96c0cf31f2600ce9c1ea133097a1d6348c4097a686443d30326936516ae565a082f7cf405b6c204db3d88b585d12 SHA512 57e510a712ac429c2b2ae2408b2c548198bfc5e3ceab61c88bd0c9ae536f462a9d89410fd2851578d443e1b9638f01353523d9c354b42e0a69b7a4f08ca1c4fa
+DIST remind-04.02.02.tar.bz2 413760 BLAKE2B d4e91b531c0e88dc4436a0399103af6c9ae8e642a8df729a49ac6be06e215705c7605424030d92761753637a68a89eea2d935347b40c1b39b626b13e4e7297db SHA512 2d10f8d0066c291d52220fc1c39cfc4948e5f1f94223780b7d4770348b5c9e06e2b8f34e1e193c06f8e74b26d3e4126fcaeea88dbf8900f064610df22e9c8739
diff --git a/app-misc/remind/files/remind-include-fix.patch b/app-misc/remind/files/remind-include-fix.patch
new file mode 100644
index 000000000000..45671f0b6289
--- /dev/null
+++ b/app-misc/remind/files/remind-include-fix.patch
@@ -0,0 +1,11 @@
+diff -Naur remind-04.02.02-orig/src/funcs.c remind-04.02.02/src/funcs.c
+--- remind-04.02.02-orig/src/funcs.c 2023-01-01 13:54:23.000000000 -0800
++++ remind-04.02.02/src/funcs.c 2023-01-19 23:05:11.147990523 -0800
+@@ -27,6 +27,7 @@
+ #include <ctype.h>
+ #include <math.h>
+ #include <sys/ioctl.h>
++#include <fcntl.h>
+
+ #include <unistd.h>
+
diff --git a/app-misc/remind/remind-04.02.02.ebuild b/app-misc/remind/remind-04.02.02.ebuild
new file mode 100644
index 000000000000..a8b7d91aa369
--- /dev/null
+++ b/app-misc/remind/remind-04.02.02.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Ridiculously functional reminder program"
+HOMEPAGE="https://dianne.skoll.ca/projects/remind/"
+SRC_URI="https://salsa.debian.org/dskoll/remind/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="tk"
+
+RDEPEND="
+ tk? ( >=dev-lang/tk-8.5 dev-tcltk/tcllib )
+"
+DEPEND="${RDEPEND}
+ dev-perl/Cairo
+ dev-perl/JSON-MaybeXS
+ dev-perl/Pango
+ virtual/perl-Getopt-Long
+"
+DOCS="docs/* examples/defs.rem "
+
+PATCHES=( "${FILESDIR}"/${PN}-include-fix.patch )
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]] ; then
+ ewarn "Testing fails if run as root. Skipping tests"
+ else
+ emake test
+ fi
+}
+
+src_install() {
+ default
+
+ if ! use tk ; then
+ rm \
+ "${D}"/usr/bin/tkremind \
+ "${D}"/usr/share/man/man1/tkremind* \
+ || die
+ fi
+
+ rm "${S}"/contrib/rem2ics-*/{Makefile,rem2ics.spec} || die
+ insinto /usr/share/${PN}
+ doins -r contrib/
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/remind.vim
+}