summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-12 19:50:17 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-12 19:50:17 +0200
commit622467f2d4781537a54e13a65dfc94ff4155bd61 (patch)
tree25eafd181408aedb735243088cdce0bfea0d08d7 /app-misc
parentdev-python/google-auth: Version bump to 1.6.3 (diff)
downloadgentoo-622467f2d4781537a54e13a65dfc94ff4155bd61.tar.gz
gentoo-622467f2d4781537a54e13a65dfc94ff4155bd61.tar.bz2
gentoo-622467f2d4781537a54e13a65dfc94ff4155bd61.zip
app-misc/votrify: Bump to v3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/votrify/Manifest1
-rw-r--r--app-misc/votrify/votrify-3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/votrify/Manifest b/app-misc/votrify/Manifest
index 84bdc7053b1f..5bb9256fc18c 100644
--- a/app-misc/votrify/Manifest
+++ b/app-misc/votrify/Manifest
@@ -1,2 +1,3 @@
DIST votrify-1.tar.gz 6936 BLAKE2B 7c9a5668842c5b1783e5c8b2341d42aa21257b96a82210c16e44bee8f71b690c7dba5acf48a39beff0189106db1fe141ef1ec30d68f25573a19a53c12618d346 SHA512 14fdb4ee185d96f416b47df7b29175cebc6e003aca7c1faf927b258f7dbe39b7ed69c4defb25900c6856b6e9abde3b03a69ca02152755d8532708b6cfb7f51a0
DIST votrify-2.tar.gz 9095 BLAKE2B 801c9ad89f93349ce6ad0d9421e9a968a511d9699454c91cc713dd3a133c4f87666de3bc3905041999a5090eb5794d6ceed89aabc997e6950d2b5a4b4bb185cc SHA512 8c3795520d6ee5d34c8aa649a24309e30da8843bcddbfc8ff0b822eab5529a621d9fa475dc6714a6de0ed1d229d3a949870666967448a23036d28af5e7da00ab
+DIST votrify-3.tar.gz 9153 BLAKE2B fdff14dd7332bd6688cb2d04d87e7cf0888aa881cac6a98961cc544182869b190ac8591545c773e7a14293ff0fac7efd646be3cc7f8d059a8e45b709051eae69 SHA512 bde636cb238e114814f1246f49c9b5f363d7c9255da4cf2f5da6cb8da19f1b970e0027b630f21b0166c73de770e5bc931b811c3326ccc790db6d1d873731ef9e
diff --git a/app-misc/votrify/votrify-3.ebuild b/app-misc/votrify/votrify-3.ebuild
new file mode 100644
index 000000000000..278667874da3
--- /dev/null
+++ b/app-misc/votrify/votrify-3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit python-single-r1
+
+DESCRIPTION="Tool for community verification of Gentoo elections"
+HOMEPAGE="https://github.com/mgorny/votrify"
+SRC_URI="https://github.com/mgorny/votrify/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-misc/gentoo-elections"
+
+src_configure() {
+ # update default location for election scripts
+ sed -i -e "s^os.path.dirname(__file__)^'${EPREFIX}/usr/lib'^" \
+ votrify-make-confirmation || die
+
+ python_fix_shebang votrify-{make,verify}-*
+}
+
+make_wrappers() {
+ local election=${1}
+
+ newbin - "votrify-${election}-make" \
+ < <(sed -e "s^@ELECTION@^${election}^" \
+ votrify-wrapper-make.bash.in || die)
+ newbin - "votrify-${election}-verify" \
+ < <(sed -e "s^@ELECTION@^${election}^" \
+ votrify-wrapper-verify.bash.in || die)
+}
+
+src_install() {
+ dobin votrify-{make,verify}-*
+ make_wrappers council-201906
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "In order to interactively create confirmation for Council 2019 election:"
+ elog " votrify-council-201906-make"
+ elog
+ elog "In order to verify the results for Council 2019 election:"
+ elog " votrify-council-201906-verify"
+}