summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-04-26 01:53:23 -0400
committerTim Harder <radhermit@gentoo.org>2017-04-26 02:22:57 -0400
commit63d0659dc276e8062f6f724701dd0e1d468542f4 (patch)
tree6cc3d62801ec86922c8f2bd6e7f03331d033cabc /app-misc
parentapp-misc/binwalk: backport patch to support backports-lzma (diff)
downloadgentoo-63d0659dc276e8062f6f724701dd0e1d468542f4.tar.gz
gentoo-63d0659dc276e8062f6f724701dd0e1d468542f4.tar.bz2
gentoo-63d0659dc276e8062f6f724701dd0e1d468542f4.zip
app-misc/binwalk: add live ebuild and py36 support
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/binwalk/binwalk-2.1.1.ebuild14
-rw-r--r--app-misc/binwalk/binwalk-9999.ebuild39
2 files changed, 49 insertions, 4 deletions
diff --git a/app-misc/binwalk/binwalk-2.1.1.ebuild b/app-misc/binwalk/binwalk-2.1.1.ebuild
index 031f4169fe83..cb146865c5a4 100644
--- a/app-misc/binwalk/binwalk-2.1.1.ebuild
+++ b/app-misc/binwalk/binwalk-2.1.1.ebuild
@@ -1,18 +1,24 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit distutils-r1
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/devttys0/binwalk.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/devttys0/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
DESCRIPTION="A tool for identifying files embedded inside firmware images"
HOMEPAGE="https://github.com/devttys0/binwalk"
-SRC_URI="https://github.com/devttys0/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
IUSE="graph"
RDEPEND="
diff --git a/app-misc/binwalk/binwalk-9999.ebuild b/app-misc/binwalk/binwalk-9999.ebuild
new file mode 100644
index 000000000000..4b5c50dcc0bc
--- /dev/null
+++ b/app-misc/binwalk/binwalk-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/devttys0/binwalk.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/devttys0/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A tool for identifying files embedded inside firmware images"
+HOMEPAGE="https://github.com/devttys0/binwalk"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="graph"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7)
+ graph? ( dev-python/pyqtgraph[opengl,${PYTHON_USEDEP}] )
+"
+
+python_install_all() {
+ local DOCS=( API.md INSTALL.md README.md )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "binwalk has many optional dependencies to automatically"
+ elog "extract/decompress data, see INSTALL.md for more details."
+ fi
+}