summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 04:14:59 +0000
committerSam James <sam@gentoo.org>2021-04-19 04:30:56 +0000
commit711c6d8e242041de9090f022176ebce28e3ebd50 (patch)
treec2b785a770151933a4793a73e6e60abaa869c4a8 /app-misc
parentapp-misc/actkbd: port to EAPI 7 (diff)
downloadgentoo-711c6d8e242041de9090f022176ebce28e3ebd50.tar.gz
gentoo-711c6d8e242041de9090f022176ebce28e3ebd50.tar.bz2
gentoo-711c6d8e242041de9090f022176ebce28e3ebd50.zip
app-misc/cdargs: port to EAPI 7, remove HTML from patch(!)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/cdargs/cdargs-1.35-r2.ebuild17
-rw-r--r--app-misc/cdargs/files/cdargs-1.35-format_security.patch89
-rw-r--r--app-misc/cdargs/files/cdargs-1.35-tinfo.patch5
3 files changed, 10 insertions, 101 deletions
diff --git a/app-misc/cdargs/cdargs-1.35-r2.ebuild b/app-misc/cdargs/cdargs-1.35-r2.ebuild
index db643cd46934..49a232fae2de 100644
--- a/app-misc/cdargs/cdargs-1.35-r2.ebuild
+++ b/app-misc/cdargs/cdargs-1.35-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools elisp-common epatch
+inherit autotools elisp-common
DESCRIPTION="Bookmarks and browser for the shell builtin cd command"
HOMEPAGE="http://www.skamphausen.de/cgi-bin/ska/CDargs"
@@ -16,7 +16,8 @@ IUSE="emacs"
DEPEND="
sys-libs/ncurses:0=
- emacs? ( >=app-editors/emacs-23.1:* )"
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
RDEPEND="${DEPEND}"
SITEFILE=50${PN}-gentoo.el
@@ -24,10 +25,11 @@ SITEFILE=50${PN}-gentoo.el
PATCHES=(
"${FILESDIR}"/${P}-format_security.patch
"${FILESDIR}"/${P}-tinfo.patch
- )
+)
src_prepare() {
- epatch "${PATCHES[@]}"
+ default
+
mv configure.{in,ac} || die
eautoreconf
}
@@ -41,12 +43,13 @@ src_compile() {
src_install() {
default
- cd "${S}/contrib" || die
+ cd "${S}"/contrib || die
insinto /usr/share/cdargs
doins cdargs-bash.sh cdargs-tcsh.csh
+
if use emacs ; then
elisp-install ${PN} cdargs.{el,elc}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
}
diff --git a/app-misc/cdargs/files/cdargs-1.35-format_security.patch b/app-misc/cdargs/files/cdargs-1.35-format_security.patch
index 978a8e92c088..525ad2434651 100644
--- a/app-misc/cdargs/files/cdargs-1.35-format_security.patch
+++ b/app-misc/cdargs/files/cdargs-1.35-format_security.patch
@@ -1,86 +1,3 @@
-<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
- "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
-<html xmlns='http://www.w3.org/1999/xhtml' xml:lang='en' lang='en'>
-<head>
-<title>cdargs.git - cdargs</title>
-<meta name='generator' content='cgit v0.10.2'/>
-<meta name='robots' content='index, nofollow'/>
-<link rel='stylesheet' type='text/css' href='/cgit-data/cgit.css'/>
-<link rel='shortcut icon' href='/favicon.ico'/>
-<link rel='alternate' title='Atom feed' href='http://pkgs.fedoraproject.org/cgit/cdargs.git/atom/cdargs-1.35_format_security.patch?h=master' type='application/atom+xml'/>
-</head>
-<body>
-<script src="https://apps.fedoraproject.org/fedmenu/js/jquery-1.11.2.min.js"></script>
-<script src="https://apps.fedoraproject.org/fedmenu/js/fedmenu.js"></script>
-
-<script>
- var base = 'https://apps.fedoraproject.org/';
- var tokens = window.location.href.split('/');
- var repo = null;
- if (tokens.length > 4 && tokens[4] != '') {
- repo = tokens[4].split('.')[0];
- }
- fedmenu({
- 'url': base + 'js/data.js',
- 'mimeType': 'application/javascript',
- 'position': 'bottom-right',
- 'package': repo,
- });
-</script>
-<div id='cgit'><table id='header'>
-<tr>
-<td class='logo' rowspan='2'><a href='/cgit/'><img src='/cgit-data/cgit.png' alt='cgit logo'/></a></td>
-<td class='main'><a href='/cgit/'>index</a> : <a title='cdargs.git' href='/cgit/cdargs.git/'>cdargs.git</a></td><td class='form'><form method='get' action=''>
-<select name='h' onchange='this.form.submit();'>
-<option value='f10'>f10</option>
-<option value='f11'>f11</option>
-<option value='f12'>f12</option>
-<option value='f13'>f13</option>
-<option value='f14'>f14</option>
-<option value='f15'>f15</option>
-<option value='f16'>f16</option>
-<option value='f17'>f17</option>
-<option value='f18'>f18</option>
-<option value='f19'>f19</option>
-<option value='f20'>f20</option>
-<option value='f21'>f21</option>
-<option value='f22'>f22</option>
-<option value='f7'>f7</option>
-<option value='f8'>f8</option>
-<option value='f9'>f9</option>
-<option value='master' selected='selected'>master</option>
-</select> <input type='submit' name='' value='switch'/></form></td></tr>
-<tr><td class='sub'>cdargs</td><td class='sub right'>Jesse Keating</td></tr></table>
-<table class='tabs'><tr><td>
-<a href='/cgit/cdargs.git/'>summary</a><a href='/cgit/cdargs.git/refs/'>refs</a><a href='/cgit/cdargs.git/log/cdargs-1.35_format_security.patch'>log</a><a class='active' href='/cgit/cdargs.git/tree/cdargs-1.35_format_security.patch'>tree</a><a href='/cgit/cdargs.git/commit/cdargs-1.35_format_security.patch'>commit</a><a href='/cgit/cdargs.git/diff/cdargs-1.35_format_security.patch'>diff</a><a href='/cgit/cdargs.git/stats/cdargs-1.35_format_security.patch'>stats</a></td><td class='form'><form class='right' method='get' action='/cgit/cdargs.git/log/cdargs-1.35_format_security.patch'>
-<select name='qt'>
-<option value='grep'>log msg</option>
-<option value='author'>author</option>
-<option value='committer'>committer</option>
-<option value='range'>range</option>
-</select>
-<input class='txt' type='text' size='10' name='q' value=''/>
-<input type='submit' value='search'/>
-</form>
-</td></tr></table>
-<div class='path'>path: <a href='/cgit/cdargs.git/tree/'>root</a>/<a href='/cgit/cdargs.git/tree/cdargs-1.35_format_security.patch'>cdargs-1.35_format_security.patch</a></div><div class='content'>blob: 3ddc550e607e9f908b891c7e3626ee256484607e (<a href='/cgit/cdargs.git/plain/cdargs-1.35_format_security.patch'>plain</a>)
-<table summary='blob content' class='blob'>
-<tr><td class='linenumbers'><pre><a id='n1' href='#n1'>1</a>
-<a id='n2' href='#n2'>2</a>
-<a id='n3' href='#n3'>3</a>
-<a id='n4' href='#n4'>4</a>
-<a id='n5' href='#n5'>5</a>
-<a id='n6' href='#n6'>6</a>
-<a id='n7' href='#n7'>7</a>
-<a id='n8' href='#n8'>8</a>
-<a id='n9' href='#n9'>9</a>
-<a id='n10' href='#n10'>10</a>
-<a id='n11' href='#n11'>11</a>
-<a id='n12' href='#n12'>12</a>
-<a id='n13' href='#n13'>13</a>
-</pre></td>
-<td class='lines'><pre><code>diff --git a/src/cdargs.cc b/src/cdargs.cc
-index e505e4e..1fdfeb8 100644
--- a/src/cdargs.cc
+++ b/src/cdargs.cc
@@ -1301,7 +1301,7 @@ void helpscreen(void) {
@@ -92,9 +9,3 @@ index e505e4e..1fdfeb8 100644
exit(1);
}
-</code></pre></td></tr></table>
-</div> <!-- class=content -->
-<div class='footer'>generated by cgit v0.10.2 at 2015-06-21 13:46:50 (GMT)</div>
-</div> <!-- id=cgit -->
-</body>
-</html>
diff --git a/app-misc/cdargs/files/cdargs-1.35-tinfo.patch b/app-misc/cdargs/files/cdargs-1.35-tinfo.patch
index d85a3b9b685c..a4ca4e28b10b 100644
--- a/app-misc/cdargs/files/cdargs-1.35-tinfo.patch
+++ b/app-misc/cdargs/files/cdargs-1.35-tinfo.patch
@@ -1,8 +1,3 @@
- configure.in | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/configure.in b/configure.in
-index a21d664..263929e 100644
--- a/configure.in
+++ b/configure.in
@@ -8,10 +8,11 @@ dnl if test "$has_curses" = "false" ; then