summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormercuriete <mercuriete@gmail.com>2021-01-18 19:36:49 +0000
committerJoonas Niilola <juippis@gentoo.org>2021-02-03 12:33:05 +0200
commit7e44924e497c51d7309c797f3379aa421099723a (patch)
treefbc3f0f29f6d5db2062534662878b4bd58ed8287 /app-misc
parentnet-wireless/wireless-regdb: Version bump to 20201120 (diff)
downloadgentoo-7e44924e497c51d7309c797f3379aa421099723a.tar.gz
gentoo-7e44924e497c51d7309c797f3379aa421099723a.tar.bz2
gentoo-7e44924e497c51d7309c797f3379aa421099723a.zip
app-misc/radeontop: bump to 1.3
Closes: https://bugs.gentoo.org/765529 Signed-off-by: Abel Garcia Dorta <mercuriete@yahoo.es> Closes: https://github.com/gentoo/gentoo/pull/19108 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/radeontop/Manifest1
-rw-r--r--app-misc/radeontop/radeontop-1.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-misc/radeontop/Manifest b/app-misc/radeontop/Manifest
index 151d26a0f7d9..f2c3f5189437 100644
--- a/app-misc/radeontop/Manifest
+++ b/app-misc/radeontop/Manifest
@@ -1 +1,2 @@
DIST radeontop-1.2.tar.gz 35319 BLAKE2B 52a92b86379c9340b8f59b3039a4ad725827e1b3ee2bb7d2f544d6ec8730e03ab1baab266edbc263195e68ca56a4e7b3f251337401775fff588fbfb8bae0751d SHA512 f36c2e418fe8add77080642e575b99c092afeda24811f33ee161a8c9341decb611f631e5511a5255089d63e172eda6836295e5795c3ebd3f5cad172f7599d862
+DIST radeontop-1.3.tar.gz 38138 BLAKE2B 41bc36c571a99a136f2d1c1d5ff1a06b1e99bccb6e01f7432b9867e2700afa9d2b5cab7f743d3560b2120642c98253313e0356af977805ada173cd3c2168acbc SHA512 cc54e0726b2a934d14ad591c7a199474b49885e6122399b282e9289610d26f3c55b3d68a7d655d88a0ff8de1a0ac0994e868fa06ae1198416aaf857a099181f1
diff --git a/app-misc/radeontop/radeontop-1.3.ebuild b/app-misc/radeontop/radeontop-1.3.ebuild
new file mode 100644
index 000000000000..78d907d41517
--- /dev/null
+++ b/app-misc/radeontop/radeontop-1.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to view Radeon GPU utilization"
+HOMEPAGE="https://github.com/clbr/radeontop"
+SRC_URI="https://github.com/clbr/radeontop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ x11-libs/libdrm
+ x11-libs/libpciaccess
+ x11-libs/libxcb
+ nls? (
+ sys-libs/ncurses:0=[unicode]
+ virtual/libintl
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ cat > include/version.h <<-EOF || die
+ #ifndef VER_H
+ #define VER_H
+
+ #define VERSION "${PV}"
+
+ #endif
+ EOF
+ >getver.sh || die
+ touch .git || die
+}
+
+src_configure() {
+ tc-export CC
+ export LIBDIR=$(get_libdir)
+ export nls=$(usex nls 1 0)
+ export amdgpu=1
+ export xcb=1
+ # Do not add -g or -s to CFLAGS
+ export plain=1
+}