summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-09-10 16:37:45 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-09-10 16:39:58 +0200
commit860c465e1d146b208ce47db6f6fbd5c84c15839c (patch)
treee5dd4d9d35f300f555ad7bfd0cdd9a4fbe877bda /app-misc
parentapp-emacs/howm: Stabilize 1.5.0 ALLARCHES, #913942 (diff)
downloadgentoo-860c465e1d146b208ce47db6f6fbd5c84c15839c.tar.gz
gentoo-860c465e1d146b208ce47db6f6fbd5c84c15839c.tar.bz2
gentoo-860c465e1d146b208ce47db6f6fbd5c84c15839c.zip
app-misc/ddcui: patch configure to not look for qthelp
Bug: https://bugs.gentoo.org/877303 Closes: https://bugs.gentoo.org/913943 Co-authored-by: Andreas Sturmlechner <asturm@gentoo.org> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ddcui/ddcui-0.2.1-r1.ebuild1
-rw-r--r--app-misc/ddcui/ddcui-0.3.0-r1.ebuild4
-rw-r--r--app-misc/ddcui/files/ddcui-0.2.1-drop-qthelp-dep.patch28
3 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/ddcui/ddcui-0.2.1-r1.ebuild b/app-misc/ddcui/ddcui-0.2.1-r1.ebuild
index 9417270f3965..f8e4a4f945f3 100644
--- a/app-misc/ddcui/ddcui-0.2.1-r1.ebuild
+++ b/app-misc/ddcui/ddcui-0.2.1-r1.ebuild
@@ -27,6 +27,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-drop-qthelp-dep.patch"
)
src_prepare() {
diff --git a/app-misc/ddcui/ddcui-0.3.0-r1.ebuild b/app-misc/ddcui/ddcui-0.3.0-r1.ebuild
index 62a5eda6aa94..c32a66e52f95 100644
--- a/app-misc/ddcui/ddcui-0.3.0-r1.ebuild
+++ b/app-misc/ddcui/ddcui-0.3.0-r1.ebuild
@@ -25,6 +25,10 @@ DEPEND="
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.2.1-drop-qthelp-dep.patch"
+)
+
src_prepare() {
# move docs to correct dir
sed -i -e "s%share/doc/ddcui%share/doc/${PF}%g" CMakeLists.txt || die
diff --git a/app-misc/ddcui/files/ddcui-0.2.1-drop-qthelp-dep.patch b/app-misc/ddcui/files/ddcui-0.2.1-drop-qthelp-dep.patch
new file mode 100644
index 000000000000..607777d5715b
--- /dev/null
+++ b/app-misc/ddcui/files/ddcui-0.2.1-drop-qthelp-dep.patch
@@ -0,0 +1,28 @@
+--- a/CMakeLists.txt 2022-08-01 15:19:36.000000000 +0200
++++ b/CMakeLists.txt 2022-10-16 14:08:37.422550810 +0200
+@@ -93,12 +93,11 @@
+
+ set(QT5_LIBRARIES Qt5::Widgets )
+ # Ensures all Qt componenets have same version:
+-find_package(Qt5 ${ddcui_qt_version} COMPONENTS Core Widgets Gui Help REQUIRED)
++find_package(Qt5 ${ddcui_qt_version} COMPONENTS Core Widgets Gui REQUIRED)
+ message( ${VERBOSE} "Qt directories:")
+ message( ${VERBOSE} " Qt5Widgets_INCLUDE_DIRS: ${Qt5Widgets_INCLUDE_DIRS}" )
+ message( ${VERBOSE} " Qt5Core_INCLUDE_DIRS: ${Qt5Core_INCLUDE_DIRS}" )
+ message( ${VERBOSE} " Qt5Gui_INCLUDE_DIRS: ${Qt5Gui_INCLUDE_DIRS}" )
+-message( ${VERBOSE} " Qt5Help_INCLUDE_DIRS: ${Qt5Help_INCLUDE_DIRS}" )
+
+ find_package (PkgConfig REQUIRED )
+ pkg_check_modules(GLIB2 REQUIRED glib-2.0>=${ddcui_glib_version})
+@@ -215,9 +214,9 @@
+ # add_compile_options(-Og -H V=1)
+
+ # redundant: ${Qt5Gui_INCLUDE_DIRS} ${Qt5Core_INCLUDE_DIRS} ${Qt5Widgets_INCLUDE_DIRS}.
+-# ${Qt5Help_INCLUDE_DIRS} is a superset of them all
+ target_include_directories(ddcui SYSTEM PRIVATE
+- ${Qt5Help_INCLUDE_DIRS}
++ ${Qt5Gui_INCLUDE_DIRS}
++ ${Qt5Widgets_INCLUDE_DIRS}
+ ${GLIB2_INCLUDE_DIRS}
+ ${DDCUTIL_INCLUDE_DIRS})
+