summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Denoncin <ddenoncin@gmail.com>2022-03-21 13:25:36 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-21 21:57:06 +0200
commit87f0fb36972840e9303e1ad0d72effe04f72955b (patch)
tree086799b19b1c95f03f15db912ae63b3b22513ed8 /app-misc
parentapp-misc/task: vbump 2.6.2 (diff)
downloadgentoo-87f0fb36972840e9303e1ad0d72effe04f72955b.tar.gz
gentoo-87f0fb36972840e9303e1ad0d72effe04f72955b.tar.bz2
gentoo-87f0fb36972840e9303e1ad0d72effe04f72955b.zip
app-misc/task: drop 2.6.1
Signed-off-by: David Denoncin <ddenoncin@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24694 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/task/task-2.6.1.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/app-misc/task/task-2.6.1.ebuild b/app-misc/task/task-2.6.1.ebuild
deleted file mode 100644
index f1d4aba890f6..000000000000
--- a/app-misc/task/task-2.6.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_MAKEFILE_GENERATOR="emake"
-inherit bash-completion-r1 cmake
-
-DESCRIPTION="Taskwarrior is a command-line todo list manager"
-HOMEPAGE="https://taskwarrior.org/"
-SRC_URI="https://github.com/GothenburgBitFactory/taskwarrior/releases/download/v${PV}/${P}.tar.gz
- https://github.com/GothenburgBitFactory/taskwarrior/releases/download/v${PV}/tests-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-IUSE="+sync"
-
-DEPEND="
- sync? ( net-libs/gnutls )
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # move test directory into source directory
- mv "${WORKDIR}"/test "${WORKDIR}"/${P} || die
-
- cmake_src_prepare
-
- # don't automatically install scripts
- sed -i '/scripts/d' CMakeLists.txt || die
-}
-
-src_configure() {
- mycmakeargs=(
- -DENABLE_SYNC=$(usex sync)
- -DTASK_DOCDIR=share/doc/${PF}
- -DTASK_RCDIR=share/${PN}/rc
- )
-
- cmake_src_configure
-}
-
-src_test() {
- cd "${WORKDIR}"/"${P}"_build || die
-
- emake test
-}
-
-src_install() {
- cmake_src_install
-
- newbashcomp scripts/bash/task.sh task
-
- # vim syntax
- rm scripts/vim/README || die
- insinto /usr/share/vim/vimfiles
- doins -r scripts/vim/*
-
- # zsh-completions
- insinto /usr/share/zsh/site-functions
- doins scripts/zsh/*
-
- exeinto "/usr/share/${PN}/scripts"
- doexe scripts/add-ons/*
-}