summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 08:57:39 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:43 +0100
commit8d81d82ef380e23cc0552c589b3c144935176dbd (patch)
tree0ac8fc95b15b5dc1e5f181b343094b3c426db59b /app-misc
parentapp-misc/dvorak7min: respect PKG_CONFIG (diff)
downloadgentoo-8d81d82ef380e23cc0552c589b3c144935176dbd.tar.gz
gentoo-8d81d82ef380e23cc0552c589b3c144935176dbd.tar.bz2
gentoo-8d81d82ef380e23cc0552c589b3c144935176dbd.zip
app-misc/wcd: respect PKG_CONFIG and depend on pkgconfig
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/wcd/files/wcd-5.2.5-gentoo.patch9
-rw-r--r--app-misc/wcd/files/wcd-5.3.4-gentoo.patch8
-rw-r--r--app-misc/wcd/files/wcd-6.0.1-gentoo.patch8
-rw-r--r--app-misc/wcd/files/wcd-6.0.2-gentoo.patch8
-rw-r--r--app-misc/wcd/wcd-5.2.7.ebuild6
-rw-r--r--app-misc/wcd/wcd-5.3.4.ebuild6
-rw-r--r--app-misc/wcd/wcd-6.0.1.ebuild6
-rw-r--r--app-misc/wcd/wcd-6.0.2.ebuild6
8 files changed, 30 insertions, 27 deletions
diff --git a/app-misc/wcd/files/wcd-5.2.5-gentoo.patch b/app-misc/wcd/files/wcd-5.2.5-gentoo.patch
index c838e131aa5f..82a1594399bd 100644
--- a/app-misc/wcd/files/wcd-5.2.5-gentoo.patch
+++ b/app-misc/wcd/files/wcd-5.2.5-gentoo.patch
@@ -1,8 +1,3 @@
- src/Makefile | 20 ++++++++++----------
- 1 file changed, 10 insertions(+), 10 deletions(-)
-
-diff --git a/src/Makefile b/src/Makefile
-index d4120cc..4505b8d 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -46,12 +46,12 @@ include version.mk
@@ -25,10 +20,10 @@ index d4120cc..4505b8d 100644
ifdef UCS
- CURSES = ncursesw
-+ CURSES = $(shell pkg-config --libs ncursesw)
++ CURSES = $(shell ${PKG_CONFIG} --libs ncursesw)
else
- CURSES = ncurses
-+ CURSES = $(shell pkg-config --libs ncurses)
++ CURSES = $(shell ${PKG_CONFIG} --libs ncurses)
endif
ifdef CURSES
diff --git a/app-misc/wcd/files/wcd-5.3.4-gentoo.patch b/app-misc/wcd/files/wcd-5.3.4-gentoo.patch
index 0839bdb069d9..aa164ce9b14d 100644
--- a/app-misc/wcd/files/wcd-5.3.4-gentoo.patch
+++ b/app-misc/wcd/files/wcd-5.3.4-gentoo.patch
@@ -1,5 +1,5 @@
---- wcd-5.3.4/src/Makefile
-+++ wcd-5.3.4/src/Makefile
+--- a/src/Makefile
++++ b/src/Makefile
@@ -46,12 +46,12 @@
CC ?= gcc
@@ -20,10 +20,10 @@
ifdef UCS
- CURSES = ncursesw
-+ CURSES = $(shell pkg-config --libs ncursesw)
++ CURSES = $(shell ${PKG_CONFIG} --libs ncursesw)
else
- CURSES = ncurses
-+ CURSES = $(shell pkg-config --libs ncurses)
++ CURSES = $(shell ${PKG_CONFIG} --libs ncurses)
endif
diff --git a/app-misc/wcd/files/wcd-6.0.1-gentoo.patch b/app-misc/wcd/files/wcd-6.0.1-gentoo.patch
index eca95856ca33..420f5d4cec31 100644
--- a/app-misc/wcd/files/wcd-6.0.1-gentoo.patch
+++ b/app-misc/wcd/files/wcd-6.0.1-gentoo.patch
@@ -1,5 +1,5 @@
---- wcd-6.0.1/src/Makefile
-+++ wcd-6.0.1/src/Makefile
+--- a/src/Makefile
++++ b/src/Makefile
@@ -45,12 +45,12 @@
CC ?= gcc
@@ -20,10 +20,10 @@
ifdef UCS
- CURSES = ncursesw
-+ CURSES = $(shell pkg-config --libs ncursesw)
++ CURSES = $(shell ${PKG_CONFIG} --libs ncursesw)
else
- CURSES = ncurses
-+ CURSES = $(shell pkg-config --libs ncurses)
++ CURSES = $(shell ${PKG_CONFIG} --libs ncurses)
endif
diff --git a/app-misc/wcd/files/wcd-6.0.2-gentoo.patch b/app-misc/wcd/files/wcd-6.0.2-gentoo.patch
index ecd7c530f156..eddeee89e046 100644
--- a/app-misc/wcd/files/wcd-6.0.2-gentoo.patch
+++ b/app-misc/wcd/files/wcd-6.0.2-gentoo.patch
@@ -1,5 +1,5 @@
---- wcd-6.0.2/src/Makefile
-+++ wcd-6.0.2/src/Makefile
+--- a/src/Makefile
++++ b/src/Makefile
@@ -45,12 +45,12 @@
CC ?= gcc
@@ -20,10 +20,10 @@
ifdef UCS
- CURSES = ncursesw
-+ CURSES = $(shell pkg-config --libs ncursesw)
++ CURSES = $(shell ${PKG_CONFIG} --libs ncursesw)
else
- CURSES = ncurses
-+ CURSES = $(shell pkg-config --libs ncurses)
++ CURSES = $(shell ${PKG_CONFIG} --libs ncurses)
endif
diff --git a/app-misc/wcd/wcd-5.2.7.ebuild b/app-misc/wcd/wcd-5.2.7.ebuild
index 8af0814c2438..e6275be727df 100644
--- a/app-misc/wcd/wcd-5.2.7.ebuild
+++ b/app-misc/wcd/wcd-5.2.7.ebuild
@@ -18,7 +18,9 @@ CDEPEND="
sys-libs/ncurses[unicode?]
unicode? ( dev-libs/libunistring )"
DEPEND="${CDEPEND}
- app-text/ghostscript-gpl"
+ app-text/ghostscript-gpl
+ virtual/pkgconfig
+"
RDEPEND="${CDEPEND}"
S="${WORKDIR}"/${P}/src
@@ -26,7 +28,7 @@ S="${WORKDIR}"/${P}/src
src_prepare() {
epatch \
"${FILESDIR}"/${PN}-5.2.5-gentoo.patch
- tc-export CC
+ tc-export CC PKG_CONFIG
}
src_compile() {
diff --git a/app-misc/wcd/wcd-5.3.4.ebuild b/app-misc/wcd/wcd-5.3.4.ebuild
index 413bbec8c181..b6b5ada63e42 100644
--- a/app-misc/wcd/wcd-5.3.4.ebuild
+++ b/app-misc/wcd/wcd-5.3.4.ebuild
@@ -18,7 +18,9 @@ CDEPEND="
sys-libs/ncurses:0=[unicode?]
unicode? ( dev-libs/libunistring )"
DEPEND="${CDEPEND}
- app-text/ghostscript-gpl"
+ app-text/ghostscript-gpl
+ virtual/pkgconfig
+"
RDEPEND="${CDEPEND}"
S="${WORKDIR}"/${P}/src
@@ -32,7 +34,7 @@ src_prepare() {
pushd .. &>/dev/null || die
default
popd &>/dev/null || die
- tc-export CC
+ tc-export CC PKG_CONFIG
}
src_compile() {
diff --git a/app-misc/wcd/wcd-6.0.1.ebuild b/app-misc/wcd/wcd-6.0.1.ebuild
index f3bd8d67e8de..3aca5740d540 100644
--- a/app-misc/wcd/wcd-6.0.1.ebuild
+++ b/app-misc/wcd/wcd-6.0.1.ebuild
@@ -18,7 +18,9 @@ CDEPEND="
sys-libs/ncurses:0=[unicode?]
unicode? ( dev-libs/libunistring )"
DEPEND="${CDEPEND}
- app-text/ghostscript-gpl"
+ app-text/ghostscript-gpl
+ virtual/pkgconfig
+"
RDEPEND="${CDEPEND}"
S="${WORKDIR}/${P}/src"
@@ -26,7 +28,7 @@ S="${WORKDIR}/${P}/src"
src_prepare() {
eapply -p2 "${FILESDIR}"/${PN}-6.0.1-gentoo.patch
eapply_user
- tc-export CC
+ tc-export CC PKG_CONFIG
}
src_compile() {
diff --git a/app-misc/wcd/wcd-6.0.2.ebuild b/app-misc/wcd/wcd-6.0.2.ebuild
index ff0d79dc7c2a..332588592bf1 100644
--- a/app-misc/wcd/wcd-6.0.2.ebuild
+++ b/app-misc/wcd/wcd-6.0.2.ebuild
@@ -18,7 +18,9 @@ CDEPEND="
sys-libs/ncurses:0=[unicode?]
unicode? ( dev-libs/libunistring )"
DEPEND="${CDEPEND}
- app-text/ghostscript-gpl"
+ app-text/ghostscript-gpl
+ virtual/pkgconfig
+"
RDEPEND="${CDEPEND}"
S="${WORKDIR}/${P}/src"
@@ -26,7 +28,7 @@ S="${WORKDIR}/${P}/src"
src_prepare() {
eapply -p2 "${FILESDIR}"/${PN}-6.0.2-gentoo.patch
eapply_user
- tc-export CC
+ tc-export CC PKG_CONFIG
}
src_compile() {