summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-09-05 23:39:38 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-09-05 23:39:50 +0200
commit9bf8da750771c938d5ebe5090fe4e05e142d0dc6 (patch)
treecaeb94cbf26f24bbd195093926d00e36c58eb938 /app-misc
parentmedia-libs/libsdl2: Fix EGL and wayland support on systems without X11. (diff)
downloadgentoo-9bf8da750771c938d5ebe5090fe4e05e142d0dc6.tar.gz
gentoo-9bf8da750771c938d5ebe5090fe4e05e142d0dc6.tar.bz2
gentoo-9bf8da750771c938d5ebe5090fe4e05e142d0dc6.zip
app-misc/datefudge: bump to v1.24
Closes: https://bugs.gentoo.org/709788 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/datefudge/Manifest1
-rw-r--r--app-misc/datefudge/datefudge-1.24.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/datefudge/Manifest b/app-misc/datefudge/Manifest
index f36e68074923..153aac25f3c1 100644
--- a/app-misc/datefudge/Manifest
+++ b/app-misc/datefudge/Manifest
@@ -1 +1,2 @@
DIST datefudge_1.22.tar.xz 12964 BLAKE2B 2f76647a3f7c73e43ff6b4fd57d57d21cae75fd8bc304a5cab7c66d9798795e2386f6219a51d71f57e13463e88a3e518160d90ae01bae5253cbcb7c8a3acf763 SHA512 ed67d334ca8296ae1c7b5ee1efc6ec7aafaad0aeb9f0f0387245c2eeea94ccc59ab804778b93ab8b34a512b83a3ec81d10f341d4f4f22b4a07fccdadaefb6d8b
+DIST datefudge_1.24.tar.xz 14152 BLAKE2B c0a386193e6761abade4643e2f56520738baf4bb739d4c94cec3e47a8feb5ebdf32a6e8b4a0c3dbb9584136b9855abcc68f5134e082083dfb61e977ae45c0bc7 SHA512 cd548a7e8ff10189e101fa339b2845cdd19a59354e43b02cf47e466855ec192dc2084951f7663a94da56a580dd24524047651d8bcb41aa478fe94b24dffaedeb
diff --git a/app-misc/datefudge/datefudge-1.24.ebuild b/app-misc/datefudge/datefudge-1.24.ebuild
new file mode 100644
index 000000000000..d9399fc46aa7
--- /dev/null
+++ b/app-misc/datefudge/datefudge-1.24.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A program (and preload library) to fake system date"
+HOMEPAGE="https://packages.qa.debian.org/d/datefudge.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/dpkg-parsechangelog/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" libdir="/usr/$(get_libdir)" VERSION="${PV}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" CC="$(tc-getCC)" libdir="/usr/$(get_libdir)" install
+ einstalldocs
+}