summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-14 10:39:47 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-05 22:17:03 +0200
commita50786bd3e18274da494d0ae2f88c6e41a8e3460 (patch)
tree3750dc383bebdde5b2acbbb1bedab6a8a26e88a8 /app-misc
parentnet-p2p/mldonkey: Replace STRIP_MASK with RESTRICT=strip (diff)
downloadgentoo-a50786bd3e18274da494d0ae2f88c6e41a8e3460.tar.gz
gentoo-a50786bd3e18274da494d0ae2f88c6e41a8e3460.tar.bz2
gentoo-a50786bd3e18274da494d0ae2f88c6e41a8e3460.zip
app-misc/ledit: Replace STRIP_MASK with RESTRICT=strip
Closes: https://bugs.gentoo.org/651426 Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/11676 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ledit/ledit-2.03.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/app-misc/ledit/ledit-2.03.ebuild b/app-misc/ledit/ledit-2.03.ebuild
index caec36f62406..4810b328c9a0 100644
--- a/app-misc/ledit/ledit-2.03.ebuild
+++ b/app-misc/ledit/ledit-2.03.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -18,15 +18,12 @@ RDEPEND="${DEPEND}"
SLOT="0"
LICENSE="BSD"
KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+RESTRICT="!ocamlopt? ( strip )"
src_compile() {
emake -j1 all
if use ocamlopt; then
emake -j1 ledit.opt
- else
- # If using bytecode we dont want to strip the binary as it would remove the
- # bytecode and only leave ocamlrun...
- export STRIP_MASK="*/bin/*"
fi
}