summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-04 20:03:09 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-04 20:03:09 +0100
commita88932223403899ae77a7885ac738e8779e83bf7 (patch)
tree643b7ac6212fdcf82f566bf12dbf9da35bf0c649 /app-misc
parentapp-text/po4a: Keyword ~riscv (diff)
downloadgentoo-a88932223403899ae77a7885ac738e8779e83bf7.tar.gz
gentoo-a88932223403899ae77a7885ac738e8779e83bf7.tar.bz2
gentoo-a88932223403899ae77a7885ac738e8779e83bf7.zip
app-misc/graphlcd-base: bump to version 2.0.1
Please note, that I am adding here on purpose stable keywords, as its the same version, as currently 2.0.0 is. The only difference is, that my vnc patch for compile fixes got merged, which is also already applied to 2.0.0, but upstream bumped after merging the patch to 2.0.1. But in order not to confuse users, I am bumping to official version. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/graphlcd-base/Manifest1
-rw-r--r--app-misc/graphlcd-base/graphlcd-base-2.0.1.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/app-misc/graphlcd-base/Manifest b/app-misc/graphlcd-base/Manifest
index f0e5c739940c..e5ea8746af06 100644
--- a/app-misc/graphlcd-base/Manifest
+++ b/app-misc/graphlcd-base/Manifest
@@ -1 +1,2 @@
DIST graphlcd-base-2.0.0.tar.bz2 522921 BLAKE2B 34223a84b11fef03d6dbd3f9d5f17362206823a5df0828b7494e88809f313ccd82ccc3ef62df129e6ccd6912a4152829a49c56024976aaf58fbf127d98b0903c SHA512 7fd0d558df16b845b4cd788f597552be85563b00d26d37181b3e0cc7cdc1a9eb00f2437b1c0dc6e9bb7851c6c9168dcc2d952898c1a371aeb8684b6c6aa8d995
+DIST graphlcd-base-2.0.1.tar.bz2 523119 BLAKE2B f918b01908f02c829a03938ec0b3c15eba466c850ac5578d123264106293d1a1fb25b8b184ea8f3f3049093cafc44828097273e9b7bde0e25515f981490abbf4 SHA512 1e745234d9f7dc6a34af75a46983fae11ed39a2dd4e0f2a5530380ee4a0e0d3aef137ebb28f28c1134bfe7bfced813783fffa3e4b45e03f4ddf4b3090dcad24f
diff --git a/app-misc/graphlcd-base/graphlcd-base-2.0.1.ebuild b/app-misc/graphlcd-base/graphlcd-base-2.0.1.ebuild
new file mode 100644
index 000000000000..1bb09fbd69cc
--- /dev/null
+++ b/app-misc/graphlcd-base/graphlcd-base-2.0.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature toolchain-funcs udev
+
+DESCRIPTION="Contains the lowlevel lcd drivers for GraphLCD"
+HOMEPAGE="https://projects.vdr-developer.org/projects/graphlcd-base"
+SRC_URI="https://projects.vdr-developer.org/git/${PN}.git/snapshot/${P}.tar.bz2"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="fontconfig freetype graphicsmagick imagemagick lcd_devices_ax206dpf lcd_devices_picolcd_256x64 lcd_devices_vnc"
+REQUIRED_USE="?? ( graphicsmagick imagemagick )"
+
+RDEPEND="
+ dev-libs/libhid
+ net-libs/libvncserver
+ freetype? ( media-libs/freetype:2= )
+ fontconfig? ( media-libs/fontconfig:1.0= )
+ graphicsmagick? ( media-gfx/graphicsmagick:0/1.3[cxx] )
+ imagemagick? ( <media-gfx/imagemagick-7 )
+ lcd_devices_ax206dpf? ( virtual/libusb:0 )
+ lcd_devices_picolcd_256x64? ( virtual/libusb:0 )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "HISTORY" "README" "TODO" "docs/." )
+
+PATCHES=( "${FILESDIR}/${PN}-2.0.0-musl.patch" )
+
+src_prepare() {
+ default
+
+ # Change '/usr/local/' to '/usr'
+ # Change '/usr/lib' to '/usr/$(get_libdir)'
+ sed -e "34s:/usr/local:/usr:" -e "37s:/lib:/$(get_libdir):" -i Make.config || die
+
+ # Fix newer GCC version with the Futaba MDM166A lcd driver
+ sed -e "s:0xff7f0004:(int) 0xff7f0004:" -i glcddrivers/futabaMDM166A.c || die
+
+ tc-export CC CXX
+}
+
+src_configure() {
+ # Build optional drivers
+ if use lcd_devices_ax206dpf; then
+ sed -e "78s:#::" -i Make.config || die
+ fi
+ if use lcd_devices_picolcd_256x64; then
+ sed -e "81s:#::" -i Make.config || die
+ fi
+ if ! use lcd_devices_vnc; then
+ sed -e "72s:1:0:" -i Make.config || die
+ fi
+
+ # Build optional features
+ if ! use freetype; then
+ sed -e "59s:HAVE:#HAVE:" -i Make.config || die
+ fi
+ if ! use fontconfig; then
+ sed -e "62s:HAVE:#HAVE:" -i Make.config || die
+ fi
+ if use graphicsmagick; then
+ sed -e "69s:#::" -i Make.config || die
+ fi
+ if use imagemagick; then
+ sed -e "68s:#::" -i Make.config || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" UDEVRULESDIR="/lib/udev/rules.d" install
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ udev_reload
+
+ optfeature "supporting the logitech g15 keyboard lcd." app-misc/g15daemon
+}
+
+pkg_postrm() {
+ udev_reload
+}