summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-15 21:52:36 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-15 21:52:36 +0200
commita9374bd89c2a17d3a5f2d97409a5ccce93c9baa1 (patch)
tree127648178646bc434614f796160594232254cc5f /app-misc
parentsys-devel/pmake: Port to EAPI 7 (diff)
downloadgentoo-a9374bd89c2a17d3a5f2d97409a5ccce93c9baa1.tar.gz
gentoo-a9374bd89c2a17d3a5f2d97409a5ccce93c9baa1.tar.bz2
gentoo-a9374bd89c2a17d3a5f2d97409a5ccce93c9baa1.zip
app-misc/ttysnoop: Port to EAPI 7
Closes: https://bugs.gentoo.org/742071 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ttysnoop/files/pinkbyte_masking.patch4
-rw-r--r--app-misc/ttysnoop/files/ttysnoop-makefile.patch27
-rw-r--r--app-misc/ttysnoop/ttysnoop-0.12d.ebuild32
3 files changed, 35 insertions, 28 deletions
diff --git a/app-misc/ttysnoop/files/pinkbyte_masking.patch b/app-misc/ttysnoop/files/pinkbyte_masking.patch
index a0539c239b04..8d944b21e3af 100644
--- a/app-misc/ttysnoop/files/pinkbyte_masking.patch
+++ b/app-misc/ttysnoop/files/pinkbyte_masking.patch
@@ -1,5 +1,5 @@
---- ttysnoops.c 2009-08-13 17:11:30.705202250 +0400
-+++ ttysnoops.c 2009-08-13 17:17:29.989201055 +0400
+--- a/ttysnoops.c
++++ b/ttysnoops.c
@@ -18,6 +18,7 @@
v0.12d 8-4-98 Carl Declerck - updated #includes a bit
k26 28-5-00 Vinicius Anselmo - added sound alert (demoniac) created by Stas
diff --git a/app-misc/ttysnoop/files/ttysnoop-makefile.patch b/app-misc/ttysnoop/files/ttysnoop-makefile.patch
index 54d04dd40a29..ba8d702e9e6e 100644
--- a/app-misc/ttysnoop/files/ttysnoop-makefile.patch
+++ b/app-misc/ttysnoop/files/ttysnoop-makefile.patch
@@ -1,6 +1,15 @@
---- Makefile 2004-06-07 04:27:40.000000000 +0400
-+++ Makefile 2011-07-21 11:50:22.580167326 +0400
-@@ -11,7 +11,7 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,8 +2,6 @@
+ # Makefile for the ttysnoop programs
+ #
+
+-CC = gcc
+-
+ # Without shadow support
+
+ #CCOPTS = -O2
+@@ -11,7 +9,7 @@
# For shadow support
@@ -9,28 +18,28 @@
LIBS = -lcrypt
#LIBS = -lshadow
-@@ -24,19 +24,19 @@
+@@ -24,19 +22,19 @@
all: ttysnoops ttysnoop
ttysnoops: $(SERVEROBJS)
- $(CC) $(SERVEROBJS) -o ttysnoops $(LIBS)
-+ $(CC) $(SERVEROBJS) -o ttysnoops $(LDFLAGS) $(LIBS)
++ $(CC) $(LDFLAGS) $(SERVEROBJS) -o ttysnoops $(LIBS)
ttysnoop: $(CLIENTOBJS)
- $(CC) $(CLIENTOBJS) -o ttysnoop $(LIBS)
-+ $(CC) $(CLIENTOBJS) -o ttysnoop $(LDFLAGS) $(LIBS)
++ $(CC) $(LDFLAGS) $(CLIENTOBJS) -o ttysnoop $(LIBS)
ttysnoops.o: $(SERVERSRCS) $(INCLUDES)
- $(CC) $(CCOPTS) -c -o ttysnoops.o $(SERVERSRCS)
-+ $(CC) $(CCOPTS) $(CFLAGS) -c -o ttysnoops.o $(SERVERSRCS)
++ $(CC) $(CCOPTS) $(CPPFLAGS) $(CFLAGS) -c -o ttysnoops.o $(SERVERSRCS)
ttysnoop.o: $(CLIENTSRCS) $(INCLUDES)
- $(CC) $(CCOPTS) -c -o ttysnoop.o $(CLIENTSRCS)
-+ $(CC) $(CCOPTS) $(CFLAGS) -c -o ttysnoop.o $(CLIENTSRCS)
++ $(CC) $(CCOPTS) $(CPPFLAGS) $(CFLAGS) -c -o ttysnoop.o $(CLIENTSRCS)
common.o: common.c common.h
- $(CC) $(CCOPTS) -c -o common.o common.c
-+ $(CC) $(CCOPTS) $(CFLAGS) -c -o common.o common.c
++ $(CC) $(CCOPTS) $(CPPFLAGS) $(CFLAGS) -c -o common.o common.c
clean:
rm -f *.o core ttysnoop ttysnoops
diff --git a/app-misc/ttysnoop/ttysnoop-0.12d.ebuild b/app-misc/ttysnoop/ttysnoop-0.12d.ebuild
index 400e1e6c2c64..ccbb8cd23f2c 100644
--- a/app-misc/ttysnoop/ttysnoop-0.12d.ebuild
+++ b/app-misc/ttysnoop/ttysnoop-0.12d.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
MY_P="${P}.k26"
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Tool to snoop on login tty's through another tty-device or pseudo-tty"
HOMEPAGE="http://sysd.org/stas/node/35"
@@ -14,30 +14,28 @@ SRC_URI="http://sysd.org/stas/files/active/0/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
-DOCS="README snooptab.dist"
-
-src_prepare() {
- epatch "${FILESDIR}"/pinkbyte_masking.patch
- epatch "${FILESDIR}"/"${PN}"-makefile.patch
-}
+PATCHES=(
+ "${FILESDIR}"/pinkbyte_masking.patch
+ "${FILESDIR}"/"${PN}"-makefile.patch
+)
-src_compile() {
- emake CC="$(tc-getCC)"
+src_configure() {
+ tc-export CC
}
src_install() {
dodir /var/spool/ttysnoop
+ keepdir /var/spool/ttysnoop
+
fperms o= /var/spool/ttysnoop
- dodoc ${DOCS}
- dosbin ttysnoop
- dosbin ttysnoops
+
+ dosbin ttysnoop ttysnoops
+
+ dodoc README snooptab.dist
+
doman ttysnoop.8
insinto /etc
newins snooptab.dist snooptab