summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2021-01-13 15:43:01 -0600
committerTony Vroon <chainsaw@gentoo.org>2021-02-03 16:08:33 +0000
commitbbbf7110d51c4aa3a47c7df4830abe7738ab432e (patch)
tree18a257342cf33ce0f482e1a86657c43d517f4245 /app-misc
parentnet-vpn/tor: version bump rc to 0.4.5.5_rc (diff)
downloadgentoo-bbbf7110d51c4aa3a47c7df4830abe7738ab432e.tar.gz
gentoo-bbbf7110d51c4aa3a47c7df4830abe7738ab432e.tar.bz2
gentoo-bbbf7110d51c4aa3a47c7df4830abe7738ab432e.zip
app-misc/ckb: Version bump to 0.4.3
This drops the GCC 10 patch, as it has been integrated upstream. The quazip USE-flag is no longer in the tree, so no longer needs to be specified. Adds an elog message informing the user that the daemon must be started before use. Closes: https://github.com/gentoo/gentoo/pull/19056 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Signed-off-by: Tony Vroon <chainsaw@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ckb/Manifest1
-rw-r--r--app-misc/ckb/ckb-0.4.3.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-misc/ckb/Manifest b/app-misc/ckb/Manifest
index fa95dc0c7403..0701fab0cdd5 100644
--- a/app-misc/ckb/Manifest
+++ b/app-misc/ckb/Manifest
@@ -1 +1,2 @@
DIST ckb-0.4.2.tar.gz 883681 BLAKE2B b3d921010b1caa8cb870770c6cf3ff0e9f6c65ea742325995e26351331e3063a16e8a391f593bfc8b16663cef0580e087d776796ea69776465122b08e00e9382 SHA512 4c80101e935a4d5137b0fd6aaf7d97889913af0bbb8e3097e035e2420043d6525094c1e3f7b5676e8c50328454251ff3260f6aa9b81ec583a2e8136333ee6af8
+DIST ckb-0.4.3.tar.gz 1588845 BLAKE2B bdf11580c8224dfe0a7d01f99e3bea1d36fa3d7c1de84ec991ee4454c838db614bd74757ec3b952d28ab672244bb4c28888f6b80366255cfb57ec37ff8742c1d SHA512 6772812fb9608251f3a14efeb16960966be446462ab3f5b1bec896761aeae9e5f5cf9c07b21e509dbef057825c3017323f82f066519cb512ebe2fc6eea6ec217
diff --git a/app-misc/ckb/ckb-0.4.3.ebuild b/app-misc/ckb/ckb-0.4.3.ebuild
new file mode 100644
index 000000000000..5a1da477ebe7
--- /dev/null
+++ b/app-misc/ckb/ckb-0.4.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg cmake
+
+DESCRIPTION="Corsair K65/K70/K95 Driver"
+HOMEPAGE="https://github.com/ckb-next/ckb-next"
+SRC_URI="https://github.com/ckb-next/ckb-next/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-libs/libdbusmenu-qt
+ dev-libs/quazip
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-sound/pulseaudio
+ virtual/libudev:=
+ x11-libs/libX11
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-wm"
+BDEPEND="dev-qt/linguist-tools:5"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-next-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_UPDATER=yes
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ dodoc CHANGELOG.md
+
+ newinitd "${FILESDIR}"/ckb.initd ckb-daemon
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "The ckb daemon will have to be started before use:"
+ elog
+ elog "OpenRC:"
+ elog "# rc-service ckb start"
+ elog
+ elog "Systemd:"
+ elog "# systemctl start ckb-next-daemon"
+ fi
+}